summaryrefslogtreecommitdiff
path: root/sys-apps/kcheck/kcheck-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /sys-apps/kcheck/kcheck-9999.ebuild
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'sys-apps/kcheck/kcheck-9999.ebuild')
-rw-r--r--sys-apps/kcheck/kcheck-9999.ebuild15
1 files changed, 9 insertions, 6 deletions
diff --git a/sys-apps/kcheck/kcheck-9999.ebuild b/sys-apps/kcheck/kcheck-9999.ebuild
index 2d83fb1a653b..d28b7022b350 100644
--- a/sys-apps/kcheck/kcheck-9999.ebuild
+++ b/sys-apps/kcheck/kcheck-9999.ebuild
@@ -1,8 +1,9 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-PYTHON_COMPAT=( python3_6 )
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
inherit distutils-r1
@@ -20,11 +21,13 @@ HOMEPAGE="https://github.com/wraeth/kcheck"
LICENSE="MIT"
SLOT="0"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-RDEPEND="dev-python/configargparse[${PYTHON_USEDEP}]"
+RDEPEND="
+ dev-python/configargparse[${PYTHON_USEDEP}]
+ sys-apps/portage[${PYTHON_USEDEP}]"
src_install() {
distutils-r1_src_install
- mkdir "${D}"etc || die
- mv -v "${D}"{usr/,}etc/kcheck.conf || die
+ mkdir "${D}"/etc || die
+ mv -v "${D}"/{usr/,}etc/kcheck.conf || die
+ rmdir -v "${D}"/usr/etc || die
}