summaryrefslogtreecommitdiff
path: root/sys-apps/iucode_tool
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-10 02:17:07 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-10 02:17:07 +0100
commited40f2eafae80bcb56715a81c92b1f9c29364bad (patch)
tree2285aa4c66618a4d8a0c94f6845a05b55c225aea /sys-apps/iucode_tool
parent69202c9dc2e21292adc03d8e2083e15f1814f321 (diff)
gentoo auto-resync : 10:08:2022 - 02:17:07
Diffstat (limited to 'sys-apps/iucode_tool')
-rw-r--r--sys-apps/iucode_tool/Manifest3
-rw-r--r--sys-apps/iucode_tool/files/iucode_tool-2.3.1-limits-include.patch10
-rw-r--r--sys-apps/iucode_tool/iucode_tool-2.3.1-r1.ebuild10
3 files changed, 20 insertions, 3 deletions
diff --git a/sys-apps/iucode_tool/Manifest b/sys-apps/iucode_tool/Manifest
index 352bb919e597..852e0ea09fe2 100644
--- a/sys-apps/iucode_tool/Manifest
+++ b/sys-apps/iucode_tool/Manifest
@@ -1,3 +1,4 @@
+AUX iucode_tool-2.3.1-limits-include.patch 200 BLAKE2B 7ed386d5431c1fe46a50f80752b8274901cd6d8b74d945d4728361af48c867aa3ef6455ff67dcf2d730f8130b6a0de8649822ab5861557c8855dd71d28b01aee SHA512 ef7ae958326efcbfd0235ceb2e428181cc63b324dedbd74444f2319dd3aa0120da3755d9089ab7c2f515eafe01ec45e6900b15f06495af73ee8908342b8e2e5f
DIST iucode-tool_2.3.1.tar.xz 153380 BLAKE2B 30dfc28e1dd4e0241cb7cfeb18bba746bb85c341a1627e21a5db4965271c26fcfe33f036c2008207bc9fa6c2f32bf2b857e78c9bf23739817d5c5c487d6010cb SHA512 2c7f72eaf509f9daa482ec5f8eb86a45ac9fa84fa856678fdf9ad056e19532e3734e04656d9dbebbd3a774d69f4c861c1340bbe67b1c6c60d61135705980e7d6
-EBUILD iucode_tool-2.3.1-r1.ebuild 425 BLAKE2B 6095ad603d5cd2340db5c23aac6c1ae0fc16d4c4617151e8b70717c47a4ad4dc1d8d83bb4bee4261b16d49b1c58d000b56bc3ff6f540e22462fc2463a02c6d01 SHA512 0fa65c955d746f9cc7725c38093a92d536cf1a176f4ebbd60306c722c5bc4eca22b1d154eaded3d69f816891b82e30dffa80cd2ad8997f9bc58d6bc24b824dc2
+EBUILD iucode_tool-2.3.1-r1.ebuild 550 BLAKE2B 5da72ea8207de1c1b8727f24233fac41ec8675e38a8894310b2fff51adaf1367c77699fc856f884fbe0489703f940aced6251d247e246a4fb54cfea6597cf0e3 SHA512 1f0009cbf9cdd5153a3965b431ab853fd50b4e866652cf2a676a65f484ce570b16624c9f5153e85bf04b4c2e65f2405c112309ab323f3c0597462a317da24502
MISC metadata.xml 254 BLAKE2B f3a9f843cf94243d1129711770df727fcdc8808bca829ef784819cab6f5410dfa463cfed85182f8228c7de796a674dd602653ad3ef817a62c0c3e7198b23befe SHA512 b9fcd3084a7e197f6138e1ce8b0eff99c4c203c37a7d5c40de207040ba1501ef0e5b2f4e00216a567037bcd6d3394fdec6ff587484c9ba2fca9d04f431733b7c
diff --git a/sys-apps/iucode_tool/files/iucode_tool-2.3.1-limits-include.patch b/sys-apps/iucode_tool/files/iucode_tool-2.3.1-limits-include.patch
new file mode 100644
index 000000000000..965bf740e3c2
--- /dev/null
+++ b/sys-apps/iucode_tool/files/iucode_tool-2.3.1-limits-include.patch
@@ -0,0 +1,10 @@
+Fixes build on musl.
+--- a/iucode_tool.c
++++ b/iucode_tool.c
+@@ -29,6 +29,7 @@
+ #include <assert.h>
+ #include <argp.h>
+ #include <dirent.h>
++#include <limits.h>
+ #include <time.h>
+ #include <cpuid.h>
diff --git a/sys-apps/iucode_tool/iucode_tool-2.3.1-r1.ebuild b/sys-apps/iucode_tool/iucode_tool-2.3.1-r1.ebuild
index cdaff636c174..b6c3cb20991d 100644
--- a/sys-apps/iucode_tool/iucode_tool-2.3.1-r1.ebuild
+++ b/sys-apps/iucode_tool/iucode_tool-2.3.1-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
@@ -10,6 +10,12 @@ SRC_URI="https://gitlab.com/iucode-tool/releases/raw/master/${PN/_/-}_${PV}.tar.
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="-* amd64 x86"
-IUSE=""
+
+RDEPEND="elibc_musl? ( sys-libs/argp-standalone )"
+DEPEND="${RDEPEND}"
S="${WORKDIR}/${PN/_/-}-${PV}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.3.1-limits-include.patch
+)