summaryrefslogtreecommitdiff
path: root/sys-apps/isapnptools/isapnptools-1.27-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-05-09 00:01:03 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-05-09 00:01:03 +0100
commita0ce545d52f231499bf9f3644493113d8af58ec9 (patch)
tree4d67c09eed0c2ae28d1317f72d7f7b08b4f6aeea /sys-apps/isapnptools/isapnptools-1.27-r1.ebuild
parent5181ced3f3566a9610b85922b083c8f84f20d78f (diff)
gentoo auto-resync : 09:05:2024 - 00:01:03
Diffstat (limited to 'sys-apps/isapnptools/isapnptools-1.27-r1.ebuild')
-rw-r--r--sys-apps/isapnptools/isapnptools-1.27-r1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/sys-apps/isapnptools/isapnptools-1.27-r1.ebuild b/sys-apps/isapnptools/isapnptools-1.27-r1.ebuild
new file mode 100644
index 000000000000..056011e4bd02
--- /dev/null
+++ b/sys-apps/isapnptools/isapnptools-1.27-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Tools for configuring ISA PnP devices"
+HOMEPAGE="https://wiki.gentoo.org/wiki/No_homepage"
+SRC_URI="ftp://metalab.unc.edu/pub/Linux/system/hardware/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-include.patch
+ "${FILESDIR}"/${P}-fno-common.patch
+ "${FILESDIR}"/${P}-incompatible-pointer-types.patch
+)
+
+src_install() {
+ default
+
+ dodir /sbin
+ mv "${ED}"/{usr/sbin/isapnp,sbin/} || die
+
+ docinto txt
+ dodoc doc/{README*,*.txt} test/*.txt
+ dodoc etc/isapnp.*
+
+ newinitd "${FILESDIR}"/isapnp.rc isapnp
+}