summaryrefslogtreecommitdiff
path: root/sys-apps/iproute2/iproute2-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-16 17:00:58 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-16 17:00:58 +0100
commit7b830374520118e805fdd214530a389653750f51 (patch)
tree1f6ef2872a3f89b278b2d5c7f82f36df335dce30 /sys-apps/iproute2/iproute2-9999.ebuild
parent3c490942d0d98701d1c0971e60911fa6bd3ecb76 (diff)
gentoo auto-resync : 16:09:2023 - 17:00:58
Diffstat (limited to 'sys-apps/iproute2/iproute2-9999.ebuild')
-rw-r--r--sys-apps/iproute2/iproute2-9999.ebuild12
1 files changed, 3 insertions, 9 deletions
diff --git a/sys-apps/iproute2/iproute2-9999.ebuild b/sys-apps/iproute2/iproute2-9999.ebuild
index 32423402a1c3..04c74af7ff25 100644
--- a/sys-apps/iproute2/iproute2-9999.ebuild
+++ b/sys-apps/iproute2/iproute2-9999.ebuild
@@ -18,7 +18,7 @@ HOMEPAGE="https://wiki.linuxfoundation.org/networking/iproute2"
LICENSE="GPL-2"
SLOT="0"
-IUSE="atm berkdb bpf caps elf +iptables libbsd minimal nfs selinux split-usr"
+IUSE="atm berkdb bpf caps elf +iptables minimal nfs selinux split-usr"
# Needs root
RESTRICT="test"
@@ -32,7 +32,6 @@ RDEPEND="
caps? ( sys-libs/libcap )
elf? ( virtual/libelf:= )
iptables? ( >=net-firewall/iptables-1.4.20:= )
- libbsd? ( dev-libs/libbsd )
nfs? ( net-libs/libtirpc:= )
selinux? ( sys-libs/libselinux )
"
@@ -50,9 +49,9 @@ BDEPEND="
PATCHES=(
"${FILESDIR}"/${PN}-3.1.0-mtu.patch # bug #291907
- "${FILESDIR}"/${PN}-5.12.0-configure-nomagic.patch # bug #643722
- #"${FILESDIR}"/${PN}-5.1.0-portability.patch
+ "${FILESDIR}"/${PN}-5.12.0-configure-nomagic-nolibbsd.patch # bug #643722 & 911727
"${FILESDIR}"/${PN}-5.7.0-mix-signal.h-include.patch
+ "${FILESDIR}"/${PN}-6.4.0-disable-libbsd-fallback.patch # bug #911727
)
src_prepare() {
@@ -138,10 +137,6 @@ src_configure() {
sed -i -e '/HAVE_SELINUX/d' config.mk || die
fi
- if ! use libbsd ; then
- sed -i -e '/HAVE_LIBBSD/d' config.mk || die
- fi
-
# ...Now switch on/off requested features via USE flags
# this is only useful if the test did not set other things, per bug #643722
# Keep in sync with ifs above, or refactor to be unified.
@@ -160,7 +155,6 @@ src_configure() {
IP_CONFIG_SETNS := ${setns}
# Use correct iptables dir, bug #144265, bug #293709
IPT_LIB_DIR := $(use iptables && ${PKG_CONFIG} xtables --variable=xtlibdir)
- HAVE_LIBBSD := $(usex libbsd y n)
EOF
}