summaryrefslogtreecommitdiff
path: root/sys-apps/intel-sa-00075-tools/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sys-apps/intel-sa-00075-tools/files
reinit the tree, so we can have metadata
Diffstat (limited to 'sys-apps/intel-sa-00075-tools/files')
-rw-r--r--sys-apps/intel-sa-00075-tools/files/intel-sa-00075-tools-makefile.patch24
1 files changed, 24 insertions, 0 deletions
diff --git a/sys-apps/intel-sa-00075-tools/files/intel-sa-00075-tools-makefile.patch b/sys-apps/intel-sa-00075-tools/files/intel-sa-00075-tools-makefile.patch
new file mode 100644
index 000000000000..3cdf418315f7
--- /dev/null
+++ b/sys-apps/intel-sa-00075-tools/files/intel-sa-00075-tools-makefile.patch
@@ -0,0 +1,24 @@
+diff --git a/Makefile b/Makefile
+index 5ccccff..f58d7bb 100644
+--- a/Makefile
++++ b/Makefile
+@@ -63,12 +63,12 @@
+ #
+ #;****************************************************************************;
+
++PREFIX := /usr
+
+ PROGS = INTEL-SA-00075-Discovery-Tool \
+ INTEL-SA-00075-Unprovisioning-Tool
+
+ all:$(PROGS)
+- strip $(PROGS)
+
+ INTEL-SA-00075-Discovery-Tool: INTEL-SA-00075-Discovery-Tool.o INTEL-SA-00075.o
+ INTEL-SA-00075-Unprovisioning-Tool: INTEL-SA-00075-Unprovisioning-Tool.o INTEL-SA-00075.o
+@@ -77,3 +77,5 @@ clean:
+ rm -f $(PROGS)
+ rm -f *.o
+
++install:
++ install -D -t $(DESTDIR)$(PREFIX)/sbin/ $(PROGS)