summaryrefslogtreecommitdiff
path: root/sys-apps/i2c-tools/i2c-tools-4.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-04-22 23:59:31 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-04-22 23:59:31 +0100
commit1f00990debeffd0052c194989d0a02baac23eb96 (patch)
treeecc3dfafe935354404f7a0689a6ad809ebaba580 /sys-apps/i2c-tools/i2c-tools-4.2.ebuild
parent02eb6576978c38afed5787f6f2dbab8353379d66 (diff)
gentoo auto-resync : 22:04:2024 - 23:59:31
Diffstat (limited to 'sys-apps/i2c-tools/i2c-tools-4.2.ebuild')
-rw-r--r--sys-apps/i2c-tools/i2c-tools-4.2.ebuild73
1 files changed, 0 insertions, 73 deletions
diff --git a/sys-apps/i2c-tools/i2c-tools-4.2.ebuild b/sys-apps/i2c-tools/i2c-tools-4.2.ebuild
deleted file mode 100644
index ed58d716a310..000000000000
--- a/sys-apps/i2c-tools/i2c-tools-4.2.ebuild
+++ /dev/null
@@ -1,73 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{9,10} )
-DISTUTILS_OPTIONAL="1"
-
-inherit distutils-r1 flag-o-matic toolchain-funcs
-
-DESCRIPTION="I2C tools for bus probing, chip dumping, EEPROM decoding, and more"
-HOMEPAGE="https://www.kernel.org/pub/software/utils/i2c-tools"
-SRC_URI="https://www.kernel.org/pub/software/utils/${PN}/${P}.tar.xz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 ~mips ppc ppc64 ~riscv sparc x86"
-IUSE="perl python"
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-
-RDEPEND="
- python? ( ${PYTHON_DEPS} )"
-DEPEND="${RDEPEND}"
-RDEPEND+="
- perl? ( dev-lang/perl )"
-
-src_prepare() {
- default
- use python && distutils-r1_src_prepare
-
- # Cut out the eeprom/ & stub/ dirs as only perl scripts live there.
- if ! use perl ; then
- sed -i '/^SRCDIRS/s: eeprom stub : :g' Makefile || die
- fi
-}
-
-src_configure() {
- use python && distutils-r1_src_configure
-
- export BUILD_DYNAMIC_LIB=1
- export USE_STATIC_LIB=0
- export BUILD_STATIC_LIB=0
-}
-
-src_compile() {
- emake AR="$(tc-getAR)" CC="$(tc-getCC)" all-lib # parallel make
- emake CC="$(tc-getCC)"
- emake -C eepromer CC="$(tc-getCC)" CFLAGS="${CFLAGS}"
-
- if use python ; then
- cd py-smbus || die
- append-cppflags -I../include
- distutils-r1_src_compile
- fi
-}
-
-src_install() {
- emake DESTDIR="${D}" libdir="/usr/$(get_libdir)" PREFIX="/usr" install-lib install
- dosbin eepromer/eeprom{,er}
- dodoc CHANGES README
- local d
- for d in $(usex perl eeprom '') eepromer ; do
- docinto "${d}"
- dodoc "${d}"/README*
- done
-
- if use python ; then
- cd py-smbus || die
- docinto py-smbus
- dodoc README*
- distutils-r1_src_install
- fi
-}