summaryrefslogtreecommitdiff
path: root/sys-apps/hwsetup/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-12-25 23:06:25 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-12-25 23:06:25 +0000
commit441d1370330332b7d78f238d2f5e13f7aed5e4e0 (patch)
tree6a5171dd615dfeee62a45044144c66e864738fb0 /sys-apps/hwsetup/files
parentab3da91fb6c91a9df52fff8f991570f456fd3c7a (diff)
gentoo christmass resync : 25.12.2020
Diffstat (limited to 'sys-apps/hwsetup/files')
-rw-r--r--sys-apps/hwsetup/files/1.2-3-fastprobe.patch74
-rw-r--r--sys-apps/hwsetup/files/1.2-7-dyn_blacklist.patch62
-rw-r--r--sys-apps/hwsetup/files/1.2-7-gentoo.patch20
-rw-r--r--sys-apps/hwsetup/files/1.2-7-openchrome.patch11
-rw-r--r--sys-apps/hwsetup/files/1.2-strip.patch11
5 files changed, 0 insertions, 178 deletions
diff --git a/sys-apps/hwsetup/files/1.2-3-fastprobe.patch b/sys-apps/hwsetup/files/1.2-3-fastprobe.patch
deleted file mode 100644
index 600b8c4002d6..000000000000
--- a/sys-apps/hwsetup/files/1.2-3-fastprobe.patch
+++ /dev/null
@@ -1,74 +0,0 @@
---- a/hwsetup.c
-+++ b/hwsetup.c
-@@ -140,14 +140,15 @@
-
- int syntax(char *option)
- {
-- printf(VERSION);
-+ puts(VERSION);
- if(option) fprintf(stderr,"hwsetup: Unknown option '%s'\n\n",option);
-- printf("Usage: hwsetup\n"
-- " -v be verbose\n"
-- " -p print rotating prompt\n"
-- " -a ignore audio devices\n"
-- " -s ignore scsi controllers\n"
-- " -n probe only, don't configure anything.\n");
-+ puts("Usage: hwsetup\n"
-+ "\t\t-v\tbe verbose\n"
-+ "\t\t-p\tprint rotating prompt\n"
-+ "\t\t-a\tignore audio devices\n"
-+ "\t\t-s\tignore scsi controllers\n"
-+ "\t\t-n\tprobe only, don't configure anything.\n"
-+ "\t\t-f\trun a fast probe.");
- return option?1:0;
- }
-
-@@ -425,7 +426,7 @@
- {
- signal(SIGALRM,SIG_IGN);
- fprintf(stderr,"\nWARNING: Autodetection seems to hang,\n"
-- "please check your computers BIOS settings.\n");
-+ "please check your computer's BIOS settings.\n");
- fflush(stderr);
- if(wpid) { kill(wpid,SIGTERM); usleep(2500000); kill(wpid,SIGKILL); wpid=0; }
- exit(1); /* exit program */
-@@ -591,12 +592,13 @@
- return 0;
- }
-
--int hw_setup(enum deviceClass dc, int verbose, int probeonly, int skip)
-+int hw_setup(enum deviceClass dc, int verbose, int probeonly, int skip, int fastprobe)
- {
- int i,mouse=0,cdrom=0,modem=0,scanner=0;
-+ int probeopt=fastprobe?PROBE_SAFE:PROBE_ALL;
- struct device **currentDevs, *d, *serialmouse=NULL, *usbmouse=NULL;
- if(verbose&VERBOSE_PROMPT) wpid=startwheel();
-- currentDevs=probeDevices(dc,BUS_UNSPEC,PROBE_ALL);
-+ currentDevs=probeDevices(dc,BUS_UNSPEC,probeopt);
- if(verbose&VERBOSE_PROMPT&&wpid>0) { kill(wpid,SIGTERM); wpid=0; usleep(160000); write(2,"\033[0m Done.\n",11); }
- if(currentDevs==NULL) return -1;
- check_proc_modules(); /* Get currently loaded module list */
-@@ -650,7 +652,7 @@
-
- int main(int argc, char **argv)
- {
-- int i, verbose=0, probeonly=0, skip=0;
-+ int i, verbose=0, probeonly=0, skip=0, fast=0;
- enum deviceClass dc=CLASS_UNSPEC;
- for(i=1;i<argc;i++)
- {
-@@ -659,6 +661,7 @@
- else if(!strcasecmp(argv[i],"-a")) skip|=SKIP_AUDIO;
- else if(!strcasecmp(argv[i],"-s")) skip|=SKIP_SCSI;
- else if(!strcasecmp(argv[i],"-n")) probeonly=1;
-+ else if(!strcasecmp(argv[i],"-f")) fast=1;
- else return syntax(argv[i]);
- }
- /* Allow SIGTERM, SIGINT: rmmod depends on this. */
-@@ -667,5 +670,5 @@
- #ifdef BLACKLIST
- gen_blacklist();
- #endif
-- return hw_setup(dc,verbose,probeonly,skip);
-+ return hw_setup(dc,verbose,probeonly,skip,fast);
- }
diff --git a/sys-apps/hwsetup/files/1.2-7-dyn_blacklist.patch b/sys-apps/hwsetup/files/1.2-7-dyn_blacklist.patch
deleted file mode 100644
index efbe0f6abfed..000000000000
--- a/sys-apps/hwsetup/files/1.2-7-dyn_blacklist.patch
+++ /dev/null
@@ -1,62 +0,0 @@
---- a/hwsetup.c
-+++ b/hwsetup.c
-@@ -51,13 +51,40 @@
- /* Do not, under any circumstances, load these modules automatically, */
- /* even if in pcitable. (libkudzu may ignore this, and the KNOPPIX */
- /* autoconfig scripts may probe them, too) */
--char *blacklist[] =
-+char *blacklist[200][200] =
- { "apm","agpgart","yenta_socket","i82092","i82365","tcic",
- "pcmcia_core","ds","ohci1394","hisax", "hisax_fcpcipnp",
- "hisax_isac","hisax_st5481",
- /* Winmodems, unusable, can block sound slot */
- "snd-atiixp-modem", "snd-intel8x0m","snd-via82xx-modem"
- };
-+
-+int blacklistsize = 13;
-+void gen_blacklist(){
-+ int n = 13;
-+ int size = 0;
-+ char *comment;
-+ char module[1024];
-+ FILE *stream;
-+
-+ if((stream = fopen ("/usr/share/hwdata/blacklist", "r")) != (FILE *)0) {
-+ while((fgets(module, 1023, stream)) != (char *)0 ) {
-+
-+ comment = strchr(module, '#');
-+ if (comment != 0) *comment = '\0';
-+ comment = strchr(module, '\n');
-+ if (comment != 0) *comment = '\0';
-+ size = strlen(module);
-+ if (size < 2) continue;
-+ strcat (module , " \0");
-+ strcpy(blacklist[n] , module);
-+ n++;
-+ if ( n == 200 ) break;
-+ //printf(module);
-+ }
-+ blacklistsize = n;
-+ }
-+}
- #endif
-
- /* If a conflicting module in a row is already loaded, the new module will not be probed anymore */
-@@ -547,7 +574,7 @@
- char *cc;
- if((m==NULL)||(!strcmp("unknown",m))||(!strcmp("ignore",m))|| check_loaded(m)) return 0;
- #ifdef BLACKLIST
-- for(i=0;i<(sizeof(blacklist)/sizeof(char*));i++)
-+ for(i=0;i<blacklistsize;i++)
- {
- if(!modcmp(blacklist[i],m))
- {
-@@ -781,5 +808,8 @@
- /* Allow SIGTERM, SIGINT: rmmod depends on this. */
- signal(SIGTERM,SIG_DFL); signal(SIGINT,SIG_DFL);
- signal(SIGALRM,alarm_handler); alarm(MAX_TIME);
-+#ifdef BLACKLIST
-+ gen_blacklist();
-+#endif
- return hw_setup(dc,verbose,probeonly,skip);
- }
diff --git a/sys-apps/hwsetup/files/1.2-7-gentoo.patch b/sys-apps/hwsetup/files/1.2-7-gentoo.patch
deleted file mode 100644
index e4fc590393fd..000000000000
--- a/sys-apps/hwsetup/files/1.2-7-gentoo.patch
+++ /dev/null
@@ -1,20 +0,0 @@
---- a/hwsetup.c
-+++ b/hwsetup.c
-@@ -388,7 +388,7 @@
- sprintf(fullpath,"%.90s%.32s",xpath,server[i]);
- if(!exists(fullpath)) continue;
- strncpy(xi.xserver,server[i],sizeof(xi.xserver));
-- }
-+ }
- }
- }
- if((xpos=strstr(d->driver,xorg))!=NULL) /* Check for Xorg */
-@@ -653,7 +653,7 @@
- int writeconfig(char *name,struct device *d,int verbose)
- {
- FILE *f,*k;
-- const char *kconfig="/etc/sysconfig/knoppix";
-+ const char *kconfig="/etc/sysconfig/gentoo";
- char *desc;
- unlink(name);
- if((f=fopen(name,"w"))==NULL)
diff --git a/sys-apps/hwsetup/files/1.2-7-openchrome.patch b/sys-apps/hwsetup/files/1.2-7-openchrome.patch
deleted file mode 100644
index fb80f9dfcb1a..000000000000
--- a/sys-apps/hwsetup/files/1.2-7-openchrome.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/hwsetup.c
-+++ b/hwsetup.c
-@@ -456,7 +456,7 @@
- else if(strcasestr(xi.xdesc,"Newport")) strcpy(xi.xmodule,"newport");
- else if(strcasestr(xi.xdesc,"Siliconmotion")||strcasestr(xi.xdesc,"Silicon Motion")) strcpy(xi.xmodule,"siliconmotion");
- else if(strcasestr(xi.xdesc,"Chips")) strcpy(xi.xmodule,"chips");
-- else if(strcasestr(xi.xdesc,"VIA ")) strcpy(xi.xmodule,"via");
-+ else if(strcasestr(xi.xdesc,"VIA ")) strcpy(xi.xmodule,"openchrome");
- }
- else strcpy(xi.xmodule,xvesa4);
- }
diff --git a/sys-apps/hwsetup/files/1.2-strip.patch b/sys-apps/hwsetup/files/1.2-strip.patch
deleted file mode 100644
index 17de636a5dc7..000000000000
--- a/sys-apps/hwsetup/files/1.2-strip.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/Makefile
-+++ b/Makefile
-@@ -3,7 +3,7 @@
- # define BLACKLIST to avoid loading potentially dangerous modules
- CFLAGS=-DBLACKLIST -Wall -fPIC
- OPT=-O2
--LDFLAGS=-s
-+#LDFLAGS=-s
- LIBS=-lkudzu -lpci
- CC=gcc
-