summaryrefslogtreecommitdiff
path: root/sys-apps/hwloc/hwloc-2.9.3-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-04-27 23:59:43 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-04-27 23:59:43 +0100
commit413421048cc2b0df9a218f0ab3cb151846809eb5 (patch)
tree3fd887035aa0f5b65d7f147ab77caa98c44c148d /sys-apps/hwloc/hwloc-2.9.3-r1.ebuild
parent3e42d1577189af123b773dc0f11e5419035308c8 (diff)
gentoo auto-resync : 27:04:2024 - 23:59:42
Diffstat (limited to 'sys-apps/hwloc/hwloc-2.9.3-r1.ebuild')
-rw-r--r--sys-apps/hwloc/hwloc-2.9.3-r1.ebuild10
1 files changed, 9 insertions, 1 deletions
diff --git a/sys-apps/hwloc/hwloc-2.9.3-r1.ebuild b/sys-apps/hwloc/hwloc-2.9.3-r1.ebuild
index 4d0252d24ecc..84c0ef23b8f9 100644
--- a/sys-apps/hwloc/hwloc-2.9.3-r1.ebuild
+++ b/sys-apps/hwloc/hwloc-2.9.3-r1.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit autotools bash-completion-r1 cuda desktop flag-o-matic systemd toolchain-funcs multilib-minimal
+inherit autotools bash-completion-r1 cuda desktop flag-o-matic systemd toolchain-funcs xdg-utils multilib-minimal
MY_PV="v$(ver_cut 1-2)"
DESCRIPTION="Displays the hardware topology in convenient formats"
@@ -127,3 +127,11 @@ multilib_src_install_all() {
find "${ED}" -name '*.la' -delete || die
newicon -s 512 "${DISTDIR}/lstopo.png" ${PN}.png
}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}