summaryrefslogtreecommitdiff
path: root/sys-apps/hwinfo/hwinfo-23.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-12-28 19:37:45 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-12-28 19:37:45 +0000
commit29eb24bde1b57b17d24078f22ee071e27f6b5348 (patch)
tree635e4a17793cef96c52a5d57d9bb4356672a347b /sys-apps/hwinfo/hwinfo-23.2.ebuild
parent1d6bc233e81d1ece6bcd5d781ed786208395d19d (diff)
gentoo auto-resync : 28:12:2023 - 19:37:44
Diffstat (limited to 'sys-apps/hwinfo/hwinfo-23.2.ebuild')
-rw-r--r--sys-apps/hwinfo/hwinfo-23.2.ebuild53
1 files changed, 0 insertions, 53 deletions
diff --git a/sys-apps/hwinfo/hwinfo-23.2.ebuild b/sys-apps/hwinfo/hwinfo-23.2.ebuild
deleted file mode 100644
index 2b1b43e95b83..000000000000
--- a/sys-apps/hwinfo/hwinfo-23.2.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit toolchain-funcs
-
-DESCRIPTION="Hardware detection tool used in SuSE Linux"
-HOMEPAGE="https://github.com/openSUSE/hwinfo/"
-SRC_URI="https://github.com/openSUSE/hwinfo/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 ppc ~riscv x86 ~amd64-linux ~x86-linux"
-
-RDEPEND="amd64? ( dev-libs/libx86emu )
- x86? ( dev-libs/libx86emu )"
-DEPEND="${RDEPEND}
- >=sys-kernel/linux-headers-2.6.17"
-BDEPEND="sys-devel/flex"
-
-src_prepare() {
- default
- # Respect AR variable.
- sed -i \
- -e 's:ar r:$(AR) r:' \
- src/{,isdn,ids,smp,hd}/Makefile || die
-
- # Respect LDFLAGS.
- sed -i -e 's:$(CC) $(CFLAGS):$(CC) $(LDFLAGS) $(CFLAGS):' src/ids/Makefile || die
-
- # Respect MAKE variable. Skip forced -pipe and -g.
- sed -i \
- -e 's:make:$(MAKE):' \
- -e 's:-pipe -g::' \
- Makefile{,.common} || die
- rm -f git2log || die
-}
-
-src_compile() {
- emake -j1 AR="$(tc-getAR)" CC="$(tc-getCC)" HWINFO_VERSION="${PV}" \
- RPM_OPT_FLAGS="${CFLAGS}" LIBDIR="${EPREFIX}/usr/$(get_libdir)"
-}
-
-src_install() {
- emake DESTDIR="${ED}" LIBDIR="/usr/$(get_libdir)" install
- keepdir /var/lib/hardware/udi
-
- dodoc README*
- docinto examples
- dodoc doc/example*.c
- doman doc/*.{1,8}
-}