summaryrefslogtreecommitdiff
path: root/sys-apps/hwids
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-06-15 14:57:03 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-06-15 14:57:03 +0100
commitd18bf1e01b65ee4bf0c804e2843b282d3d4e5d7c (patch)
tree4a95cbc6ffdf13bad6ecbc7f8d5af99631984123 /sys-apps/hwids
parente748ba9741f6540f4675c23e3e37b73e822c13a4 (diff)
gentoo resync : 15.06.2021
Diffstat (limited to 'sys-apps/hwids')
-rw-r--r--sys-apps/hwids/Manifest2
-rw-r--r--sys-apps/hwids/hwids-20210613.ebuild89
2 files changed, 91 insertions, 0 deletions
diff --git a/sys-apps/hwids/Manifest b/sys-apps/hwids/Manifest
index bfd083c08464..0d9989595d79 100644
--- a/sys-apps/hwids/Manifest
+++ b/sys-apps/hwids/Manifest
@@ -1,4 +1,6 @@
DIST hwids-20201207.tar.gz 3749352 BLAKE2B a968e6daf5686c4f73d9d900fbe80a5b3844c006102ed8801f88e378dc43c1bb66aaeced42bc2703a9c8ad624a1a7167bba485b1bf0c0d0e6043920e015c9177 SHA512 ec638edd1bbf00bd66e9baa50e3b9c9a5004a96a359e6bea306f1509c69bb3c7ede3569174007ab8bde11d49300da452b06be96136cde6bd2d84a76cff9251c2
+DIST hwids-20210613.tar.gz 3867741 BLAKE2B 64c4b0a83058a2052f7b132241008a3cc75452e93a9a57a9159c357c23fd09ee256abc2b94e700b5d8e8bd4e231ae12932d2c2f32fb03853207739cb3387047d SHA512 4568f6b8c0ca80ec772bd2785d4dc169d1d13a721472a15399158d9a7f31abbe414c5c8cfdf1a3b81cce4e33742a4b6e005e97e3e907643d0afdc8e953624fea
EBUILD hwids-20201207.ebuild 1671 BLAKE2B c7740e0c4a2b694af30d91f420052ee16c4fac29e6e632ca6d9cbfc9803b774c0c53e7ed8447d30f567e48215bf6cf5323d48cb74041465db14b0f67d603393b SHA512 c8fe09cb6e4523afca06a06fc271414062d89248fd56ae729dcdf513c34c3c9834cb64369a359d97df0b80f369b44b7fb711530b42666dfadbfeeb29147ee674
+EBUILD hwids-20210613.ebuild 1679 BLAKE2B de1de81c5d19bae11225bfaea5f981e439abffa93be1bdbb48bafb599690d200e77ad3ccd170af733dc63ee16bbee8926cac042fcf99aedf927ec4ef7c38a1ff SHA512 5522bb815f7631778194b329d7365e28969b3fc0ce005022cc01d7c7729fa278df2968e541b4217b0167e819ae784b296b63a62b24f08b8f06cf1f27d6750b96
EBUILD hwids-99999999.ebuild 1679 BLAKE2B 6f3c0dc51d9598239348f1abfaf3f2c691b5c060dd21ab31fb79ccf4d9c240791a7ea061ae31aae201b15456459981ce1e06d15838b5dc136526c940dfc5c4d2 SHA512 f3a949dbda15206076e48d996bcbf6d9b1568a4338511dfbc05e87d6102eb5b08dffedf23cc24f06d2f9f17bc7247802e6229f01e23c5098b49b3768c0eb9c58
MISC metadata.xml 647 BLAKE2B 88b205060dbd1c22edb25b740b5b84d0b36e8746a8bfd5793ab385afa2afd34e54626c2b09e59dc2cf91d838ae44dea878be26cd9cab83a98054a3d0b4bfbd52 SHA512 b05dbd41c2a839d2ac8baaf8ee2352ee999d48deb123c54e048da44cccb06f64729620983848a6b16ada8af50e6fb68adf15323ff362f230b7213f485b1ec27c
diff --git a/sys-apps/hwids/hwids-20210613.ebuild b/sys-apps/hwids/hwids-20210613.ebuild
new file mode 100644
index 000000000000..6f60de83bdb6
--- /dev/null
+++ b/sys-apps/hwids/hwids-20210613.ebuild
@@ -0,0 +1,89 @@
+# Copyright 2012-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit udev
+
+DESCRIPTION="Hardware (PCI, USB, OUI, IAB) IDs databases"
+HOMEPAGE="https://github.com/gentoo/hwids"
+if [[ ${PV} == 99999999 ]]; then
+ PYTHON_COMPAT=( python3_{6..9} )
+ inherit git-r3 python-any-r1
+ EGIT_REPO_URI="https://github.com/gentoo/hwids.git"
+else
+ SRC_URI="https://github.com/gentoo/hwids/archive/${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+fi
+
+LICENSE="|| ( GPL-2 BSD ) public-domain"
+SLOT="0"
+IUSE="+net +pci +udev +usb"
+
+RDEPEND="
+ udev? ( virtual/udev )
+"
+
+if [[ ${PV} == 99999999 ]]; then
+ BDEPEND="
+ net-misc/curl
+ udev? ( $(python_gen_any_dep 'dev-python/pyparsing[${PYTHON_USEDEP}]') )
+ "
+ python_check_deps() {
+ if use udev; then
+ has_version -b "dev-python/pyparsing[${PYTHON_USEDEP}]"
+ fi
+ }
+else
+ S=${WORKDIR}/hwids-${P}
+fi
+
+pkg_setup() {
+ :
+}
+
+src_unpack() {
+ if [[ ${PV} == 99999999 ]]; then
+ git-r3_src_unpack
+ cd "${S}" || die
+ emake fetch
+ else
+ default
+ fi
+}
+
+src_prepare() {
+ default
+ sed -i -e '/udevadm hwdb/d' Makefile || die
+}
+
+_emake() {
+ emake \
+ NET=$(usex net) \
+ PCI=$(usex pci) \
+ UDEV=$(usex udev) \
+ USB=$(usex usb) \
+ "$@"
+}
+
+src_compile() {
+ if [[ ${PV} == 99999999 ]] && use udev; then
+ python_setup
+ _emake udev-hwdb
+ fi
+ _emake
+}
+
+src_install() {
+ _emake install \
+ DOCDIR="${EPREFIX}/usr/share/doc/${PF}" \
+ MISCDIR="${EPREFIX}/usr/share/misc" \
+ HWDBDIR="${EPREFIX}$(get_udevdir)/hwdb.d" \
+ DESTDIR="${D}"
+}
+
+pkg_postinst() {
+ if use udev; then
+ udevadm hwdb --update --root="${ROOT}"
+ fi
+}