summaryrefslogtreecommitdiff
path: root/sys-apps/hwdata/hwdata-0.375.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-04 05:50:31 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-04 05:50:31 +0100
commit08b4047e14c989cfb931eff95973837f54ccc9e1 (patch)
tree8ef8443bb119630d0bdea4b374a58981490b6f0e /sys-apps/hwdata/hwdata-0.375.ebuild
parentc410d7a91a496a4fbbca686c80f7446305222d55 (diff)
gentoo auto-resync : 04:10:2023 - 05:50:30
Diffstat (limited to 'sys-apps/hwdata/hwdata-0.375.ebuild')
-rw-r--r--sys-apps/hwdata/hwdata-0.375.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/sys-apps/hwdata/hwdata-0.375.ebuild b/sys-apps/hwdata/hwdata-0.375.ebuild
new file mode 100644
index 000000000000..afddd20d2fd1
--- /dev/null
+++ b/sys-apps/hwdata/hwdata-0.375.ebuild
@@ -0,0 +1,28 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit edo
+
+DESCRIPTION="Hardware identification and configuration data"
+HOMEPAGE="https://github.com/vcrhonek/hwdata"
+SRC_URI="https://github.com/vcrhonek/hwdata/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RESTRICT="test"
+
+src_configure() {
+ # configure is not compatible with econf
+ local conf=(
+ ./configure
+ --prefix="${EPREFIX}/usr"
+ --libdir="${EPREFIX}/lib"
+ --datadir="${EPREFIX}/usr/share"
+ )
+
+ edo "${conf[@]}"
+}