summaryrefslogtreecommitdiff
path: root/sys-apps/hwdata/hwdata-0.364.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-03 09:11:25 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-03 09:11:25 +0000
commit06c8293a57349047e228438cc7936e7481ab9159 (patch)
tree6da8926004f93c8934f99c570e0953bd8fb2edf3 /sys-apps/hwdata/hwdata-0.364.ebuild
parent670a2ef95331c60f32a0831bfe79445340356b0b (diff)
gentoo auto-resync : 03:11:2022 - 09:11:25
Diffstat (limited to 'sys-apps/hwdata/hwdata-0.364.ebuild')
-rw-r--r--sys-apps/hwdata/hwdata-0.364.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/sys-apps/hwdata/hwdata-0.364.ebuild b/sys-apps/hwdata/hwdata-0.364.ebuild
new file mode 100644
index 000000000000..9df06b92fe5f
--- /dev/null
+++ b/sys-apps/hwdata/hwdata-0.364.ebuild
@@ -0,0 +1,28 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit edo
+
+DESCRIPTION="Hardware identification and configuration data"
+HOMEPAGE="https://github.com/vcrhonek/hwdata"
+SRC_URI="https://github.com/vcrhonek/hwdata/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RESTRICT="test"
+
+src_configure() {
+ # configure is not compatible with econf
+ local conf=(
+ ./configure
+ --prefix="${EPREFIX}/usr"
+ --libdir="${EPREFIX}/lib"
+ --datadir="${EPREFIX}/usr/share"
+ )
+
+ edo "${conf[@]}"
+}