summaryrefslogtreecommitdiff
path: root/sys-apps/gsmartcontrol/gsmartcontrol-1.1.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-11-15 17:13:45 +0000
committerV3n3RiX <venerix@redcorelinux.org>2017-11-15 17:13:45 +0000
commite2d84e38284aeb9d522a7e935554340ddf0e4a6f (patch)
tree5a7444ee5f2af59431481999f729676090b1e0f3 /sys-apps/gsmartcontrol/gsmartcontrol-1.1.3.ebuild
parent519e4d5d99fc43d5c9a038098c029dc4ef9d6792 (diff)
gentoo resync : 15.11.2017
Diffstat (limited to 'sys-apps/gsmartcontrol/gsmartcontrol-1.1.3.ebuild')
-rw-r--r--sys-apps/gsmartcontrol/gsmartcontrol-1.1.3.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/sys-apps/gsmartcontrol/gsmartcontrol-1.1.3.ebuild b/sys-apps/gsmartcontrol/gsmartcontrol-1.1.3.ebuild
new file mode 100644
index 000000000000..4757ae7e2385
--- /dev/null
+++ b/sys-apps/gsmartcontrol/gsmartcontrol-1.1.3.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit flag-o-matic gnome2-utils
+
+DESCRIPTION="Hard disk drive health inspection tool"
+HOMEPAGE="https://gsmartcontrol.sourceforge.io/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="|| ( GPL-2 GPL-3 ) Boost-1.0 BSD Unlicense ZLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+COMMON_DEPEND="
+ dev-cpp/gtkmm:3.0
+ dev-libs/libpcre:3
+ sys-apps/smartmontools
+"
+RDEPEND="${COMMON_DEPEND}
+ x11-apps/xmessage
+"
+DEPEND="${COMMON_DEPEND}
+ virtual/pkgconfig
+ test? ( dev-util/gtk-builder-convert )
+"
+
+DOCS="TODO" # See 'dist_doc_DATA' value in Makefile.am
+
+src_prepare() {
+ default
+ append-cxxflags -std=c++11
+}
+
+src_configure() {
+ econf $(use test tests)
+}
+
+src_install() {
+ default
+ rm -f "${ED}"/usr/share/doc/${PF}/LICENSE_* || die
+}
+
+pkg_preinst() { gnome2_icon_savelist; }
+pkg_postinst() { gnome2_icon_cache_update; }
+pkg_postrm() { gnome2_icon_cache_update; }