summaryrefslogtreecommitdiff
path: root/sys-apps/gradm/files/respect-gentoo-env-r3.patch
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sys-apps/gradm/files/respect-gentoo-env-r3.patch
reinit the tree, so we can have metadata
Diffstat (limited to 'sys-apps/gradm/files/respect-gentoo-env-r3.patch')
-rw-r--r--sys-apps/gradm/files/respect-gentoo-env-r3.patch42
1 files changed, 42 insertions, 0 deletions
diff --git a/sys-apps/gradm/files/respect-gentoo-env-r3.patch b/sys-apps/gradm/files/respect-gentoo-env-r3.patch
new file mode 100644
index 000000000000..7c899b139745
--- /dev/null
+++ b/sys-apps/gradm/files/respect-gentoo-env-r3.patch
@@ -0,0 +1,42 @@
+diff -Naur gradm2.orig/Makefile gradm2/Makefile
+--- gradm2.orig/Makefile 2013-08-09 16:28:37.000000000 -0400
++++ gradm2/Makefile 2013-08-10 07:57:12.000000000 -0400
+@@ -18,18 +18,18 @@
+ BISON=/usr/bin/bison
+ #YACC := $(shell if [ -x $(BYACC) ]; then echo $(BYACC); else echo $(BISON); fi)
+ YACC=$(BISON)
+-MKNOD=/bin/mknod
++MKNOD=true
+ #for dietlibc
+ #CC=/usr/bin/diet /usr/bin/gcc
+ CC=/usr/bin/gcc
+ FIND=/usr/bin/find
+-STRIP=/usr/bin/strip
++STRIP=true
+ LIBS := $(shell if [ "`uname -m`" != "sparc64" -a "`uname -m`" != "x86_64" ]; then echo "-lfl" ; else echo "" ; fi)
+ OPT_FLAGS := -O2
+ # for older versions of grsecurity, comment the above line and uncomment the below:
+ #OPT_FLAGS := $(shell if [ "`uname -m`" != "sparc64" ] && [ "`uname -m`" != "x86_64" ]; then echo "-O2" ; else echo "-O2 -m64" ; fi)
+-CFLAGS := $(OPT_FLAGS) -fPIE -Wcast-qual -DGRSEC_DIR=\"$(GRSEC_DIR)\" -D_LARGEFILE64_SOURCE
+-LDFLAGS= -pie
++CFLAGS := $(OPT_FLAGS) -fPIE -Wcast-qual -DGRSEC_DIR=\"$(GRSEC_DIR)\" -D_LARGEFILE64_SOURCE $(CFLAGS)
++LDFLAGS+= -pie
+ INSTALL = /usr/bin/install -c
+
+ # FHS
+@@ -167,10 +167,11 @@
+ $(MKNOD) -m 0622 $(DESTDIR)/dev/grsec c 1 13 ; \
+ fi \
+ fi
+- @if [ -d $(DESTDIR)/etc/udev/rules.d ] ; then \
+- echo "ACTION!=\"add|change\", GOTO=\"permissions_end\"" > $(DESTDIR)/etc/udev/rules.d/80-grsec.rules ; \
+- echo "KERNEL==\"grsec\", MODE=\"0622\"" >> $(DESTDIR)/etc/udev/rules.d/80-grsec.rules ; \
+- echo "LABEL=\"permissions_end\"" >> $(DESTDIR)/etc/udev/rules.d/80-grsec.rules ; \
++ @mkdir -p $(DESTDIR)/lib/udev/rules.d
++ @if [ -d $(DESTDIR)/lib/udev/rules.d ] ; then \
++ echo "ACTION!=\"add|change\", GOTO=\"permissions_end\"" > $(DESTDIR)/lib/udev/rules.d/80-grsec.rules ; \
++ echo "KERNEL==\"grsec\", MODE=\"0622\"" >> $(DESTDIR)/lib/udev/rules.d/80-grsec.rules ; \
++ echo "LABEL=\"permissions_end\"" >> $(DESTDIR)/lib/udev/rules.d/80-grsec.rules ; \
+ fi
+ @if [ -f $(DESTDIR)/sbin/udevadm ] ; then \
+ $(DESTDIR)/sbin/udevadm trigger --action=change ; \