summaryrefslogtreecommitdiff
path: root/sys-apps/goawk/goawk-1.24.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-07-20 07:07:08 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-07-20 07:07:08 +0100
commitaaa44376d7162304219748a3b6771d9a26fc80fe (patch)
tree62d3e3eea5cc8134a92a731a756d15bfd8fe0177 /sys-apps/goawk/goawk-1.24.0.ebuild
parent6f97f3b697516aeae25033ec37234739fff23fbc (diff)
gentoo auto-resync : 20:07:2023 - 07:07:07
Diffstat (limited to 'sys-apps/goawk/goawk-1.24.0.ebuild')
-rw-r--r--sys-apps/goawk/goawk-1.24.0.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/sys-apps/goawk/goawk-1.24.0.ebuild b/sys-apps/goawk/goawk-1.24.0.ebuild
new file mode 100644
index 000000000000..e138a7adbd3d
--- /dev/null
+++ b/sys-apps/goawk/goawk-1.24.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit go-module
+
+DESCRIPTION="POSIX-compliant AWK interpreter written in Go, with CSV support"
+HOMEPAGE="https://github.com/benhoyt/goawk"
+SRC_URI="https://github.com/benhoyt/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+
+src_compile() {
+ ego build
+}
+
+src_test() {
+ ego test
+}
+
+src_install() {
+ einstalldocs
+
+ dobin goawk
+}