summaryrefslogtreecommitdiff
path: root/sys-apps/gentoo-systemd-integration
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
commit7bc9c63c9da678a7e6fceb095d56c634afd22c56 (patch)
tree4a67d50a439e9af63947e5f8b6ba3719af98b6c9 /sys-apps/gentoo-systemd-integration
parentb284a3168fa91a038925d2ecf5e4791011ea5e7d (diff)
gentoo resync : 15.12.2019
Diffstat (limited to 'sys-apps/gentoo-systemd-integration')
-rw-r--r--sys-apps/gentoo-systemd-integration/Manifest2
-rw-r--r--sys-apps/gentoo-systemd-integration/gentoo-systemd-integration-8.ebuild32
2 files changed, 34 insertions, 0 deletions
diff --git a/sys-apps/gentoo-systemd-integration/Manifest b/sys-apps/gentoo-systemd-integration/Manifest
index 86d043268888..26aa6f2eeb74 100644
--- a/sys-apps/gentoo-systemd-integration/Manifest
+++ b/sys-apps/gentoo-systemd-integration/Manifest
@@ -1,4 +1,6 @@
DIST gentoo-systemd-integration-7.tar.gz 64243 BLAKE2B 389c6627af6eca9b4a0854d35751a8cb45cdb2795c7b621e96e9d5bcc13a80fe1cb109c0cb2bfd9d33f7642fd08198a0afbd5b4e5956ea6ba8dc89cf4635d9c0 SHA512 cd47caa01d73da57998b6b37d89cbeb53fa722c7f4a31bb03d03762350490cde1db3ce06090df6b6ff25c1cafb40f6c2186efbd52156ebc6d078b4a59d6fef52
+DIST gentoo-systemd-integration-8.tar.bz2 53734 BLAKE2B 711f1f6603fa40e81fe32809a32f61486ab068b1f636502ac36d58e4c204b5f0d46f51a6624f134a457f246b520614213cf45cc5397de769b315e01e32720bcf SHA512 373892ca9ae8845673f9ddad74e0be0b71af944e109adf0d2ce8e54a9c24ffff5e90cfa92e74b7abc1e7d7b1598404258b90b549697bde28a1025a2d974e991f
EBUILD gentoo-systemd-integration-7.ebuild 795 BLAKE2B 2c805a1b5ce121177976d0b617dca47124dff234dedfa506928eb850d5c040db89aee7b78d731535104118d074db65c634ebbe7b4e849c134e3a84307ca68671 SHA512 9c9e95d6f959f361db79972ff2eec3e3b5a07d42589d6e6756d77f937e1d5aafdd591c44fb866b361e8e67c67398acb5cdaeca37786b21d907f375d48275721e
+EBUILD gentoo-systemd-integration-8.ebuild 735 BLAKE2B a1d3366124cc457a5537ae08cde3d0005a9d5cf47f0015743b759e9f0f5cf550f31f6380d4b6f515a3f28812acf2d8a64a3f47ebad413a2609326c58757e1130 SHA512 8045e9fe159ccbb4640c69a0986cb46094bb7358e0b0ed6b6b1d262ccd01f6a9e4be9862fd0213cb1b26fcab005aaa5ebb30df80f47424ccc76d2001e2f6939a
EBUILD gentoo-systemd-integration-9999.ebuild 729 BLAKE2B 24adcb67d253b61a09eee0df7ee78cbcafc01c3e60f5d114351204f456cdd4c138f5c27c311e72ef80e976458424266c2b9d979aa1c8022887e7b01936975841 SHA512 bd37d55941397bf4aefda23375d58892a480d4348548a543d5a0d5139acfba677082e4c14eb839a9e9b77952fb86dd32623e0b9f255a36cc32ad9327d32ce345
MISC metadata.xml 355 BLAKE2B e2e7d95fe4d4f671d0b8a24bee9db8c458232ceed374b7ed902f724ca5971cebb81acc19fe62a6d53bf98cff4c7b999d3dbcf674426e46accda3d591d6009545 SHA512 b590b927b555441da6f665dbf637ffaa27651f074a62d1738959c5913f45ee648146f9054e07ade42d5f28f93cb350b43c94299a50506d01d446de22ebacdbc0
diff --git a/sys-apps/gentoo-systemd-integration/gentoo-systemd-integration-8.ebuild b/sys-apps/gentoo-systemd-integration/gentoo-systemd-integration-8.ebuild
new file mode 100644
index 000000000000..9ad1ea02babe
--- /dev/null
+++ b/sys-apps/gentoo-systemd-integration/gentoo-systemd-integration-8.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+if [[ ${PV} == 9999 ]]; then
+ EGIT_REPO_URI="https://anongit.gentoo.org/git/proj/gentoo-systemd-integration.git"
+ inherit autotools git-r3
+else
+ SRC_URI="https://dev.gentoo.org/~mgorny/dist/${P}.tar.bz2"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+fi
+
+inherit systemd
+
+DESCRIPTION="systemd integration files for Gentoo"
+HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Systemd"
+
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND=">=sys-apps/systemd-207
+ !sys-fs/eudev
+ !sys-fs/udev"
+DEPEND=">=sys-apps/systemd-207
+ virtual/pkgconfig"
+
+src_prepare() {
+ default
+ [[ ${PV} != 9999 ]] || eautoreconf
+}