summaryrefslogtreecommitdiff
path: root/sys-apps/gentoo-systemd-integration/gentoo-systemd-integration-7.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sys-apps/gentoo-systemd-integration/gentoo-systemd-integration-7.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'sys-apps/gentoo-systemd-integration/gentoo-systemd-integration-7.ebuild')
-rw-r--r--sys-apps/gentoo-systemd-integration/gentoo-systemd-integration-7.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/sys-apps/gentoo-systemd-integration/gentoo-systemd-integration-7.ebuild b/sys-apps/gentoo-systemd-integration/gentoo-systemd-integration-7.ebuild
new file mode 100644
index 000000000000..7a5689085273
--- /dev/null
+++ b/sys-apps/gentoo-systemd-integration/gentoo-systemd-integration-7.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+if [[ ${PV} == 9999 ]]; then
+ EGIT_REPO_URI="https://anongit.gentoo.org/git/proj/gentoo-systemd-integration.git"
+ inherit autotools git-r3
+else
+ SRC_URI="https://dev.gentoo.org/~floppym/dist/${P}.tar.gz"
+ KEYWORDS="alpha amd64 arm ~arm64 ia64 ppc ppc64 sparc x86"
+fi
+
+inherit systemd
+
+DESCRIPTION="systemd integration files for Gentoo"
+HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Systemd"
+
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND=">=sys-apps/systemd-207
+ !sys-fs/eudev
+ !sys-fs/udev"
+DEPEND=">=sys-apps/systemd-207
+ virtual/pkgconfig"
+
+if [[ ${PV} == 9999 ]]; then
+ DEPEND+=" sys-devel/systemd-m4"
+fi
+
+src_prepare() {
+ default
+ [[ ${PV} != 9999 ]] || eautoreconf
+}