summaryrefslogtreecommitdiff
path: root/sys-apps/gentoo-functions/gentoo-functions-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-29 09:06:52 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-29 09:06:52 +0100
commit23fb10c075a74a6504647a16c3e06a6378e208c8 (patch)
treeb465c5421ab9289b4ae5f2af17cb3e239d42d8c5 /sys-apps/gentoo-functions/gentoo-functions-9999.ebuild
parent66cd90d4284850abdf808a598a77040bcda88bd8 (diff)
gentoo auto-resync : 29:07:2022 - 09:06:52
Diffstat (limited to 'sys-apps/gentoo-functions/gentoo-functions-9999.ebuild')
-rw-r--r--sys-apps/gentoo-functions/gentoo-functions-9999.ebuild11
1 files changed, 5 insertions, 6 deletions
diff --git a/sys-apps/gentoo-functions/gentoo-functions-9999.ebuild b/sys-apps/gentoo-functions/gentoo-functions-9999.ebuild
index 6ab30b8f6eb4..cf5513d3fcf8 100644
--- a/sys-apps/gentoo-functions/gentoo-functions-9999.ebuild
+++ b/sys-apps/gentoo-functions/gentoo-functions-9999.ebuild
@@ -1,24 +1,23 @@
-# Copyright 2014-2021 Gentoo Authors
+# Copyright 2014-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
if [[ ${PV} == 9999* ]]; then
inherit git-r3
EGIT_REPO_URI="https://anongit.gentoo.org/git/proj/gentoo-functions.git"
else
- SRC_URI="https://gitweb.gentoo.org/proj/gentoo-functions.git/snapshot/${P}.tar.gz"
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris ~x86-winnt"
+ SRC_URI="https://gitweb.gentoo.org/proj/gentoo-functions.git/snapshot/${P}.tar.bz2"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris ~x86-winnt"
fi
inherit toolchain-funcs flag-o-matic
-DESCRIPTION="base functions required by all Gentoo systems"
+DESCRIPTION="Base functions required by all Gentoo systems"
HOMEPAGE="https://gitweb.gentoo.org/proj/gentoo-functions.git"
LICENSE="GPL-2"
SLOT="0"
-IUSE=""
src_configure() {
tc-export CC