summaryrefslogtreecommitdiff
path: root/sys-apps/gcp/gcp-0.1.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sys-apps/gcp/gcp-0.1.3.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'sys-apps/gcp/gcp-0.1.3.ebuild')
-rw-r--r--sys-apps/gcp/gcp-0.1.3.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/sys-apps/gcp/gcp-0.1.3.ebuild b/sys-apps/gcp/gcp-0.1.3.ebuild
new file mode 100644
index 000000000000..6c8ec4f32909
--- /dev/null
+++ b/sys-apps/gcp/gcp-0.1.3.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="File copying utility with progress and I/O indicator"
+HOMEPAGE="http://wiki.goffi.org/wiki/Gcp/en"
+SRC_URI="ftp://ftp.goffi.org/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="dev-python/progressbar[${PYTHON_USEDEP}]
+ dev-python/pygobject:2[${PYTHON_USEDEP}]
+ dev-python/dbus-python[${PYTHON_USEDEP}]"
+
+src_prepare() {
+ default
+ sed -e '/use_setuptools/d' \
+ -e 's#.\+share/doc.\+#],#' -i setup.py || die
+}