summaryrefslogtreecommitdiff
path: root/sys-apps/gawk/gawk-4.1.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-06-30 08:49:38 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-06-30 08:49:38 +0100
commitb2be182d49eea46686b5cf2680d457df61e89dc4 (patch)
treec66442ced2011c5ca81c3114cc51041e314c6d33 /sys-apps/gawk/gawk-4.1.3.ebuild
parente23cdda4dbb0c83b9e682ab5e916085a35203da5 (diff)
gentoo resync : 30.06.2018
Diffstat (limited to 'sys-apps/gawk/gawk-4.1.3.ebuild')
-rw-r--r--sys-apps/gawk/gawk-4.1.3.ebuild72
1 files changed, 0 insertions, 72 deletions
diff --git a/sys-apps/gawk/gawk-4.1.3.ebuild b/sys-apps/gawk/gawk-4.1.3.ebuild
deleted file mode 100644
index 26bb3ec3627e..000000000000
--- a/sys-apps/gawk/gawk-4.1.3.ebuild
+++ /dev/null
@@ -1,72 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="5"
-
-inherit eutils toolchain-funcs multilib
-
-DESCRIPTION="GNU awk pattern-matching language"
-HOMEPAGE="https://www.gnu.org/software/gawk/gawk.html"
-SRC_URI="mirror://gnu/gawk/${P}.tar.xz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="mpfr nls readline"
-
-RDEPEND="mpfr? ( dev-libs/mpfr:0= )
- readline? ( sys-libs/readline:0= )"
-DEPEND="${RDEPEND}
- nls? ( sys-devel/gettext )"
-
-src_prepare() {
- # use symlinks rather than hardlinks, and disable version links
- sed -i \
- -e '/^LN =/s:=.*:= $(LN_S):' \
- -e '/install-exec-hook:/s|$|\nfoo:|' \
- Makefile.in doc/Makefile.in || die
- sed -i '/^pty1:$/s|$|\n_pty1:|' test/Makefile.in #413327
-
- EPATCH_OPTS="-Z" \
- epatch "${FILESDIR}/${P}-bsd_configure_readline.patch" #507468
-}
-
-src_configure() {
- export ac_cv_libsigsegv=no
- econf \
- --libexec='$(libdir)/misc' \
- $(use_with mpfr) \
- $(use_enable nls) \
- $(use_with readline)
-}
-
-src_install() {
- rm -rf README_d # automatic dodocs barfs
- default
-
- # Install headers
- insinto /usr/include/awk
- doins *.h || die
- rm "${ED}"/usr/include/awk/config.h || die
-}
-
-pkg_postinst() {
- # symlink creation here as the links do not belong to gawk, but to any awk
- if has_version app-admin/eselect \
- && has_version app-eselect/eselect-awk ; then
- eselect awk update ifunset
- else
- local l
- for l in "${EROOT}"usr/share/man/man1/gawk.1* "${EROOT}"usr/bin/gawk; do
- [[ -e ${l} && ! -e ${l/gawk/awk} ]] && ln -s "${l##*/}" "${l/gawk/awk}"
- done
- [[ ! -e ${EROOT}bin/awk ]] && ln -s "../usr/bin/gawk" "${EROOT}bin/awk"
- fi
-}
-
-pkg_postrm() {
- if has_version app-admin/eselect \
- && has_version app-eselect/eselect-awk ; then
- eselect awk update ifunset
- fi
-}