summaryrefslogtreecommitdiff
path: root/sys-apps/gawk/gawk-3.1.8.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sys-apps/gawk/gawk-3.1.8.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'sys-apps/gawk/gawk-3.1.8.ebuild')
-rw-r--r--sys-apps/gawk/gawk-3.1.8.ebuild77
1 files changed, 77 insertions, 0 deletions
diff --git a/sys-apps/gawk/gawk-3.1.8.ebuild b/sys-apps/gawk/gawk-3.1.8.ebuild
new file mode 100644
index 000000000000..9647eae39c9d
--- /dev/null
+++ b/sys-apps/gawk/gawk-3.1.8.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="2"
+
+inherit eutils toolchain-funcs multilib
+
+DESCRIPTION="GNU awk pattern-matching language"
+HOMEPAGE="https://www.gnu.org/software/gawk/gawk.html"
+SRC_URI="mirror://gnu/gawk/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~sparc-fbsd ~x86-fbsd"
+IUSE="nls"
+
+RDEPEND="!>=virtual/awk-1"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+
+SFFS=${WORKDIR}/filefuncs
+
+src_unpack() {
+ unpack ${A}
+
+ # Copy filefuncs module's source over ...
+ cp -r "${FILESDIR}"/filefuncs "${SFFS}" || die "cp failed"
+}
+
+src_prepare() {
+ # use symlinks rather than hardlinks, and disable version links
+ sed -i \
+ -e '/^LN =/s:=.*:= $(LN_S):' \
+ -e '/install-exec-hook:/s|$|\nfoo:|' \
+ Makefile.in doc/Makefile.in
+}
+
+src_configure() {
+ export ac_cv_libsigsegv=no
+ econf \
+ --libexec='$(libdir)/misc' \
+ $(use_enable nls) \
+ --enable-switch
+}
+
+src_compile() {
+ emake || die
+ emake -C "${SFFS}" CC="$(tc-getCC)" || die "filefuncs emake failed"
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die
+ emake -C "${SFFS}" LIBDIR="$(get_libdir)" install || die
+
+ # Keep important gawk in /bin
+ if use userland_GNU ; then
+ dodir /bin
+ mv "${D}"/usr/bin/gawk "${D}"/bin/ || die
+ dosym /bin/gawk /usr/bin/gawk
+
+ # Provide canonical `awk`
+ dosym gawk /bin/awk
+ dosym gawk /usr/bin/awk
+ dosym gawk.1 /usr/share/man/man1/awk.1
+ fi
+
+ # Install headers
+ insinto /usr/include/awk
+ doins *.h || die
+ # We do not want 'acconfig.h' in there ...
+ rm -f "${D}"/usr/include/awk/acconfig.h
+
+ dodoc AUTHORS ChangeLog FUTURES LIMITATIONS NEWS PROBLEMS POSIX.STD README README_d/*.*
+ for x in */ChangeLog ; do
+ newdoc ${x} ${x##*/}.${x%%/*}
+ done
+}