summaryrefslogtreecommitdiff
path: root/sys-apps/fwupdate/fwupdate-10.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-01-26 15:48:02 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-01-26 15:48:02 +0000
commit38b7258d086dd5e263c3bbe3880c8c956676bc71 (patch)
tree6fce284d5bfddaf597a490ac66069d16c6a485db /sys-apps/fwupdate/fwupdate-10.ebuild
parent0ebf740b9c9bc7c10ac41bea315ecc6c01c79166 (diff)
gentoo resync : 25.01.2018
Diffstat (limited to 'sys-apps/fwupdate/fwupdate-10.ebuild')
-rw-r--r--sys-apps/fwupdate/fwupdate-10.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/sys-apps/fwupdate/fwupdate-10.ebuild b/sys-apps/fwupdate/fwupdate-10.ebuild
new file mode 100644
index 000000000000..ac5e222c9472
--- /dev/null
+++ b/sys-apps/fwupdate/fwupdate-10.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit mount-boot toolchain-funcs
+
+DESCRIPTION="Tools for using the ESRT and UpdateCapsule() to apply firmware updates"
+HOMEPAGE="https://github.com/rhinstaller/fwupdate"
+SRC_URI="https://github.com/rhinstaller/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-libs/popt
+ >=sys-libs/efivar-32-r1
+ >=sys-libs/libsmbios-2.3.2
+"
+DEPEND="
+ ${RDEPEND}
+ sys-boot/gnu-efi
+"
+
+do_make() {
+ emake \
+ CC="$(tc-getCC)" \
+ EFIDIR="gentoo" \
+ GNUEFIDIR="/usr/$(get_libdir)" \
+ "${@}"
+}
+
+src_prepare() {
+ default
+
+ # Remove -Werror
+ sed 's@ -Werror\([[:space:]]\|\n\)@\1@' -i linux/Makefile || die
+}
+
+src_compile() {
+ do_make
+}
+
+src_install() {
+ do_make DESTDIR="${D}" install
+}