summaryrefslogtreecommitdiff
path: root/sys-apps/frandom/frandom-1.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sys-apps/frandom/frandom-1.1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'sys-apps/frandom/frandom-1.1.ebuild')
-rw-r--r--sys-apps/frandom/frandom-1.1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/sys-apps/frandom/frandom-1.1.ebuild b/sys-apps/frandom/frandom-1.1.ebuild
new file mode 100644
index 000000000000..50c0b257f584
--- /dev/null
+++ b/sys-apps/frandom/frandom-1.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit linux-mod udev
+
+DESCRIPTION="Fast kernel-land pseudo-random number generator using the RC4 algorithm"
+HOMEPAGE="http://billauer.co.il/frandom.html"
+SRC_URI="mirror://sourceforge/project/frandom//${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RESTRICT="strip"
+
+BUILD_TARGETS="default"
+BUILD_TARGET_ARCH="${ARCH}"
+MODULE_NAMES="frandom(misc)"
+
+src_prepare() {
+ sed -i -e "s:\$(shell uname -r):${KV_FULL}:" "${S}"/Makefile || die "sed failed"
+}
+
+src_install() {
+ linux-mod_src_install
+
+ udev_dorules "${S}"/10-${PN}.rules
+}