summaryrefslogtreecommitdiff
path: root/sys-apps/findutils
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-10-26 00:10:07 +0100
committerV3n3RiX <venerix@koprulu.sector>2021-10-26 00:10:07 +0100
commit95461df035e3867364495f065e5e805bf629b2d7 (patch)
tree867dce371a84a696e91be255d89f282975aa0480 /sys-apps/findutils
parent46eedbedafdb0040c37884982d4c775ce277fb7b (diff)
gentoo resync : 25.10.2021
Diffstat (limited to 'sys-apps/findutils')
-rw-r--r--sys-apps/findutils/Manifest1
-rw-r--r--sys-apps/findutils/findutils-4.8.0-r1.ebuild76
2 files changed, 77 insertions, 0 deletions
diff --git a/sys-apps/findutils/Manifest b/sys-apps/findutils/Manifest
index a83aa94468da..952ef27cd32f 100644
--- a/sys-apps/findutils/Manifest
+++ b/sys-apps/findutils/Manifest
@@ -1,3 +1,4 @@
DIST findutils-4.8.0.tar.xz 1983096 BLAKE2B e1f030ef11c252d33e92bf58dca20a6dd681938aad74b1bbd2bf64a0d175d64c8edac1edce71d13379e04a27e47ffa6099e105bb731957cf5247ffe01d856538 SHA512 eaa2da304dbeb2cd659b9210ac37da1bde4cd665c12a818eca98541c5ed5cba1050641fc0c39c0a446a5a7a87a8d654df0e0e6b0cee21752ea485188c9f1071e
+EBUILD findutils-4.8.0-r1.ebuild 1933 BLAKE2B 41f79a4ce6b1988586d3d0fb7cd3d959a0bb927500b7cdffe0c358b0bce65d3dc8b2fe69a28473619fa71d69b0af66b5a24738e43f387bf81588071429875227 SHA512 0549e1c7e1f47508d2bca533c0b8a7a535b476f6879b2c103d8c93fd32854ed01041d92fe327cac9ce78004ececbf52ef55b58ee59cca1d6b67e71a2774bae0d
EBUILD findutils-4.8.0.ebuild 1863 BLAKE2B 7e463fd8ff4115740d91e97fc9a74c2dd998665c632ffe956a51ac43f52b8a0cb843513fdc4b6464809544de013f0288eaad0bf475358ef1d82bd1c153442866 SHA512 fa42b34ec7d561a5e4143f3690f0df99e53b678722c58ba83f7f286d9fea0e2bf248e7c10ecb630b907d406858c87e5292d21b34c414ca201b76fb951c97f33d
MISC metadata.xml 333 BLAKE2B 321643b5c847879de4e8c0a4abebd5534e91fc7e58313ec3258520fc1f1266f98cc1892b57589cd1427ad4a0cea39b3c03ce12741b04f75290346fddc6c245fe SHA512 b36dfd42e3af70bc1ef3c7629297a390dced3edb1dc3d7d10d7672ff532da743453d9382cb15d3102885150c2440bd85019865d61c4e4342004db2dcf993f0a2
diff --git a/sys-apps/findutils/findutils-4.8.0-r1.ebuild b/sys-apps/findutils/findutils-4.8.0-r1.ebuild
new file mode 100644
index 000000000000..659a7bb9835f
--- /dev/null
+++ b/sys-apps/findutils/findutils-4.8.0-r1.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit flag-o-matic python-any-r1
+
+DESCRIPTION="GNU utilities for finding files"
+HOMEPAGE="https://www.gnu.org/software/findutils/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="nls selinux static test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="selinux? ( sys-libs/libselinux )
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ test? ( ${PYTHON_DEPS} )
+"
+BDEPEND="
+ nls? ( sys-devel/gettext )
+"
+
+pkg_setup() {
+ use test && python-any-r1_pkg_setup
+}
+
+src_prepare() {
+ # Don't build or install locate because it conflicts with mlocate,
+ # which is a secure version of locate. See bug 18729
+ sed \
+ -e '/^SUBDIRS/s@locate@@' \
+ -e '/^built_programs/s@ frcode locate updatedb@@' \
+ -i Makefile.in || die
+
+ default
+}
+
+src_configure() {
+ append-lfs-flags #471102
+ append-cppflags -D_TIME_BITS=64
+
+ if use static; then
+ append-flags -pthread
+ append-ldflags -static
+ fi
+
+ if [[ ${CHOST} == *-darwin* ]] ; then
+ # https://lists.gnu.org/archive/html/bug-findutils/2021-01/msg00050.html
+ # https://lists.gnu.org/archive/html/bug-findutils/2021-01/msg00051.html
+ append-cppflags '-D__nonnull\(X\)='
+ fi
+
+ program_prefix=$(usex userland_GNU '' g)
+ local myeconfargs=(
+ --with-packager="Gentoo"
+ --with-packager-version="${PVR}"
+ --with-packager-bug-reports="https://bugs.gentoo.org/"
+ --program-prefix=${program_prefix}
+ $(use_enable nls)
+ $(use_with selinux)
+ --libexecdir='$(libdir)'/find
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_compile() {
+ # We don't build locate, but the docs want a file in there.
+ emake -C locate dblocation.texi
+ default
+}