summaryrefslogtreecommitdiff
path: root/sys-apps/ethtool/ethtool-6.7.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-02-02 11:45:20 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-02-02 11:45:20 +0000
commit7e3d6dcede5749fe6a1adef4e673a9dde7703b7b (patch)
treed4b1fc995691d4c2cde45fc9d9875e80e85fda73 /sys-apps/ethtool/ethtool-6.7.ebuild
parentcc4bdc5d184af171efd67a1b32de966071ee18d3 (diff)
gentoo auto-resync : 02:02:2024 - 11:45:20
Diffstat (limited to 'sys-apps/ethtool/ethtool-6.7.ebuild')
-rw-r--r--sys-apps/ethtool/ethtool-6.7.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/sys-apps/ethtool/ethtool-6.7.ebuild b/sys-apps/ethtool/ethtool-6.7.ebuild
new file mode 100644
index 000000000000..e2e14f39f01b
--- /dev/null
+++ b/sys-apps/ethtool/ethtool-6.7.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Utility for examining and tuning ethernet-based network interfaces"
+HOMEPAGE="https://www.kernel.org/pub/software/network/ethtool/"
+SRC_URI="https://www.kernel.org/pub/software/network/ethtool/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="+netlink"
+
+RDEPEND="netlink? ( net-libs/libmnl )"
+DEPEND="${RDEPEND}"
+BDEPEND="app-arch/xz-utils"
+
+src_configure() {
+ econf $(use_enable netlink)
+}