summaryrefslogtreecommitdiff
path: root/sys-apps/ethtool/ethtool-6.5.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-13 10:44:02 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-13 10:44:02 +0100
commit57dbe782fa3930bfa59520388f90ca4c2f037785 (patch)
treecab5bb5fd36f7758c6ba15635a713eadc3ee5754 /sys-apps/ethtool/ethtool-6.5.ebuild
parent7bb2a634b4e693c8545db3823c080e6edec25e77 (diff)
gentoo auto-resync : 13:09:2023 - 10:44:02
Diffstat (limited to 'sys-apps/ethtool/ethtool-6.5.ebuild')
-rw-r--r--sys-apps/ethtool/ethtool-6.5.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/sys-apps/ethtool/ethtool-6.5.ebuild b/sys-apps/ethtool/ethtool-6.5.ebuild
new file mode 100644
index 000000000000..a7eff7664c78
--- /dev/null
+++ b/sys-apps/ethtool/ethtool-6.5.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Utility for examining and tuning ethernet-based network interfaces"
+HOMEPAGE="https://www.kernel.org/pub/software/network/ethtool/"
+SRC_URI="https://www.kernel.org/pub/software/network/ethtool/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="+netlink"
+
+RDEPEND="netlink? ( net-libs/libmnl )"
+DEPEND="${RDEPEND}"
+BDEPEND="app-arch/xz-utils"
+
+src_configure() {
+ econf $(use_enable netlink)
+}