summaryrefslogtreecommitdiff
path: root/sys-apps/elfix/elfix-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-04-28 20:02:04 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-04-28 20:02:04 +0100
commita4e2a46beb5e4858ef27bdedbb0ff6d2ced430ad (patch)
tree852c90a4bf354c30ea66504f70bfab5401fba18d /sys-apps/elfix/elfix-9999.ebuild
parent5e8702bcbbed438e6c6cce023e7ef0cc9baa3e02 (diff)
gentoo resync : 28.04.2018
Diffstat (limited to 'sys-apps/elfix/elfix-9999.ebuild')
-rw-r--r--sys-apps/elfix/elfix-9999.ebuild25
1 files changed, 12 insertions, 13 deletions
diff --git a/sys-apps/elfix/elfix-9999.ebuild b/sys-apps/elfix/elfix-9999.ebuild
index 9e35e46644dc..0eaa5ebdfecf 100644
--- a/sys-apps/elfix/elfix-9999.ebuild
+++ b/sys-apps/elfix/elfix-9999.ebuild
@@ -1,13 +1,11 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI="5"
+EAPI=6
-inherit eutils
-
-if [[ ${PV} == "9999" ]] ; then
- EGIT_REPO_URI="git://anongit.gentoo.org/proj/elfix.git"
- inherit git-2
+if [[ ${PV} == *9999* ]] ; then
+ EGIT_REPO_URI="https://anongit.gentoo.org/git/proj/elfix.git"
+ inherit autotools git-r3
else
SRC_URI="https://dev.gentoo.org/~blueness/elfix/${P}.tar.gz"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
@@ -21,6 +19,8 @@ LICENSE="GPL-3"
SLOT="0"
IUSE="+ptpax +xtpax"
+DOCS=( AUTHORS ChangeLog INSTALL README.md THANKS TODO )
+
REQUIRED_USE="|| ( ptpax xtpax )"
# These only work with a properly configured PaX kernel
@@ -33,7 +33,11 @@ DEPEND="~dev-python/pypax-${PV}[ptpax=,xtpax=]
RDEPEND="${DEPEND}"
src_prepare() {
- [[ ${PV} == "9999" ]] && ./autogen.sh
+ default
+ if [[ ${PV} == *9999* ]]; then
+ eautoreconf
+ cd doc && ./make.sh || die
+ fi
}
src_configure() {
@@ -42,8 +46,3 @@ src_configure() {
$(use_enable ptpax) \
$(use_enable xtpax)
}
-
-src_install() {
- emake DESTDIR="${D}" install
- dodoc AUTHORS ChangeLog INSTALL README THANKS TODO
-}