summaryrefslogtreecommitdiff
path: root/sys-apps/eless/eless-0.7.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /sys-apps/eless/eless-0.7.ebuild
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'sys-apps/eless/eless-0.7.ebuild')
-rw-r--r--sys-apps/eless/eless-0.7.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/sys-apps/eless/eless-0.7.ebuild b/sys-apps/eless/eless-0.7.ebuild
new file mode 100644
index 000000000000..8c50f4917789
--- /dev/null
+++ b/sys-apps/eless/eless-0.7.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Use Emacs as a paginator"
+HOMEPAGE="https://eless.scripter.co/ https://github.com/kaushalmodi/eless/"
+SRC_URI="https://github.com/kaushalmodi/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+RESTRICT="test" # Tests have to be run manually
+
+RDEPEND="
+ >=app-editors/emacs-25.3:*
+ app-shells/bash
+ dev-lang/perl
+"
+
+src_compile() {
+ : # Nothing to compile
+}
+
+src_install() {
+ dobin ${PN}
+ dodoc ${PN}.org README.org
+ doinfo docs/${PN}.info
+}