summaryrefslogtreecommitdiff
path: root/sys-apps/earlyoom/earlyoom-1.6.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-03 10:28:17 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-03 10:28:17 +0000
commitd99093fb4bb5652015c06274d64083daa2439e4f (patch)
treecf61513204d97974179580065e85df5c8009087c /sys-apps/earlyoom/earlyoom-1.6.2.ebuild
parent463397cf1e064185110fe57c568d73f99a06f5d1 (diff)
gentoo resync : 03.03.2021
Diffstat (limited to 'sys-apps/earlyoom/earlyoom-1.6.2.ebuild')
-rw-r--r--sys-apps/earlyoom/earlyoom-1.6.2.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/sys-apps/earlyoom/earlyoom-1.6.2.ebuild b/sys-apps/earlyoom/earlyoom-1.6.2.ebuild
new file mode 100644
index 000000000000..196ec0b0a555
--- /dev/null
+++ b/sys-apps/earlyoom/earlyoom-1.6.2.ebuild
@@ -0,0 +1,49 @@
+# Copyright 2020-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit systemd
+
+DESCRIPTION="Early OOM Daemon for Linux"
+HOMEPAGE="https://github.com/rfjakob/earlyoom"
+
+LICENSE="MIT-with-advertising"
+SLOT="0"
+if [ "${PV}" = "9999" ]; then
+ EGIT_REPO_URI="https://github.com/rfjakob/earlyoom.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/rfjakob/earlyoom/archive/v$PV.tar.gz -> $P.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+IUSE="docs systemd test"
+
+RDEPEND=""
+DEPEND=""
+BDEPEND="
+ docs? ( app-text/pandoc )
+ test? ( dev-lang/go )
+"
+
+#tests don't work
+RESTRICT=test
+
+src_compile() {
+ VERSION="v${PV}" emake earlyoom
+ use docs && VERSION="v${PV}" emake earlyoom.1
+ use systemd && emake PREFIX=/usr earlyoom.service
+}
+
+src_install() {
+ dobin earlyoom
+ use docs && doman earlyoom.1
+
+ insinto /etc/default
+ newins earlyoom.default earlyoom
+ dodir /etc/conf.d
+ ln -s ../default/earlyoom "${ED}/etc/conf.d/earlyoom"
+
+ newinitd "${FILESDIR}/${PN}-r1" "${PN}"
+ use systemd && systemd_dounit earlyoom.service
+}