summaryrefslogtreecommitdiff
path: root/sys-apps/dtc/dtc-1.4.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sys-apps/dtc/dtc-1.4.1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'sys-apps/dtc/dtc-1.4.1.ebuild')
-rw-r--r--sys-apps/dtc/dtc-1.4.1.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/sys-apps/dtc/dtc-1.4.1.ebuild b/sys-apps/dtc/dtc-1.4.1.ebuild
new file mode 100644
index 000000000000..02891c229018
--- /dev/null
+++ b/sys-apps/dtc/dtc-1.4.1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="4"
+
+inherit multilib toolchain-funcs
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="git://git.kernel.org/pub/scm/utils/dtc/dtc.git"
+ inherit git-2
+else
+ SRC_URI="mirror://kernel/software/utils/${PN}/${P}.tar.xz"
+ KEYWORDS="amd64 arm ~arm64 ppc ppc64 x86"
+fi
+
+DESCRIPTION="Open Firmware device tree compiler"
+HOMEPAGE="http://devicetree.org/Device_Tree_Compiler"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="static-libs"
+
+RDEPEND=""
+DEPEND="app-arch/xz-utils
+ sys-devel/flex
+ sys-devel/bison"
+
+src_prepare() {
+ sed -i \
+ -e '/^CFLAGS =/s:=:+=:' \
+ -e '/^CPPFLAGS =/s:=:+=:' \
+ -e 's:-Werror::' \
+ -e 's:-g -Os::' \
+ -e "/^PREFIX =/s:=.*:= ${EPREFIX}/usr:" \
+ -e "/^LIBDIR =/s:=.*:= \$(PREFIX)/$(get_libdir):" \
+ Makefile || die
+ tc-export AR CC
+ export V=1
+}
+
+src_test() {
+ emake check
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ use static-libs || find "${ED}" -name '*.a' -delete
+ dodoc Documentation/manual.txt
+}