summaryrefslogtreecommitdiff
path: root/sys-apps/dmidecode/dmidecode-3.5-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-09 05:33:51 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-09 05:33:51 +0100
commit3e1b17a1a1b2bac1314c0ea171fbd05bb098f02b (patch)
tree894494ae2d3f739b3d903c4331c6ac82b57f14e4 /sys-apps/dmidecode/dmidecode-3.5-r2.ebuild
parent900dd293f8087dff1643b45d7b836702a9ea8fd9 (diff)
gentoo auto-resync : 09:04:2023 - 05:33:50
Diffstat (limited to 'sys-apps/dmidecode/dmidecode-3.5-r2.ebuild')
-rw-r--r--sys-apps/dmidecode/dmidecode-3.5-r2.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/sys-apps/dmidecode/dmidecode-3.5-r2.ebuild b/sys-apps/dmidecode/dmidecode-3.5-r2.ebuild
new file mode 100644
index 000000000000..b9fa80eb0516
--- /dev/null
+++ b/sys-apps/dmidecode/dmidecode-3.5-r2.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# Upstream often give "recommended patches" at https://www.nongnu.org/dmidecode/
+# Check regularly after releases!
+inherit flag-o-matic toolchain-funcs
+
+DESCRIPTION="DMI (Desktop Management Interface) table related utilities"
+HOMEPAGE="https://www.nongnu.org/dmidecode/"
+SRC_URI="https://savannah.nongnu.org/download/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* ~alpha ~amd64 ~arm ~arm64 ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~x86 ~x86-solaris"
+IUSE="selinux"
+
+RDEPEND="selinux? ( sec-policy/selinux-dmidecode )"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-backport-HPE-OEM-record-137-fix.patch
+)
+
+src_prepare() {
+ default
+
+ sed -i \
+ -e "/^prefix/s:/usr/local:${EPREFIX}/usr:" \
+ -e "/^docdir/s:dmidecode:${PF}:" \
+ -e '/^PROGRAMS !=/d' \
+ Makefile || die
+}
+
+src_compile() {
+ append-lfs-flags
+
+ emake \
+ CFLAGS="${CFLAGS} ${CPPFLAGS}" \
+ LDFLAGS="${LDFLAGS}" \
+ CC="$(tc-getCC)"
+}
+
+pkg_postinst() {
+ if [[ ${CHOST} == *-solaris* ]] ; then
+ einfo "dmidecode needs root privileges to read /dev/xsvc"
+ einfo "To make dmidecode useful, either run as root, or chown and setuid the binary."
+ einfo "Note that /usr/sbin/ptrconf and /usr/sbin/ptrdiag give similar"
+ einfo "information without requiring root privileges."
+ fi
+}