summaryrefslogtreecommitdiff
path: root/sys-apps/cpuid/cpuid-20240409.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-04-18 12:04:39 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-04-18 12:04:39 +0100
commit2d01b3d133c0fbf17de8d7b47905585af88bd6e4 (patch)
treef74eb9a3d16ed25f8c15b825f4d28b759ae99a42 /sys-apps/cpuid/cpuid-20240409.ebuild
parent97bacba3ead078e5db8b87ab651a3ffa7d82f60f (diff)
gentoo auto-resync : 18:04:2024 - 12:04:39
Diffstat (limited to 'sys-apps/cpuid/cpuid-20240409.ebuild')
-rw-r--r--sys-apps/cpuid/cpuid-20240409.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/sys-apps/cpuid/cpuid-20240409.ebuild b/sys-apps/cpuid/cpuid-20240409.ebuild
new file mode 100644
index 000000000000..c2868c0d5525
--- /dev/null
+++ b/sys-apps/cpuid/cpuid-20240409.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Linux tool to dump x86 CPUID information about the CPUs"
+HOMEPAGE="http://www.etallen.com/cpuid.html"
+SRC_URI="http://www.etallen.com/${PN}/${P}.src.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+
+BDEPEND="
+ app-alternatives/gzip
+ dev-lang/perl
+"
+
+DOCS=( "ChangeLog" "FUTURE" )
+
+PATCHES=( "${FILESDIR}/${PN}-20220620-makefile.patch" )
+
+src_prepare() {
+ default
+
+ tc-export CC
+}
+
+src_install() {
+ emake BUILDROOT="${ED}" install
+
+ einstalldocs
+}