summaryrefslogtreecommitdiff
path: root/sys-apps/cpuid/cpuid-20230614.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-06-25 01:28:26 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-06-25 01:28:26 +0100
commit9fce2d9787c37a690336f5e345a49d83ee60bc8a (patch)
tree0dabdf3dfaf12e3782b5551f1c84f30f19d22bec /sys-apps/cpuid/cpuid-20230614.ebuild
parentd2f5fa9c5505a5c3df8170b498e890f50dfc9553 (diff)
gentoo auto-resync : 25:06:2023 - 01:28:26
Diffstat (limited to 'sys-apps/cpuid/cpuid-20230614.ebuild')
-rw-r--r--sys-apps/cpuid/cpuid-20230614.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/sys-apps/cpuid/cpuid-20230614.ebuild b/sys-apps/cpuid/cpuid-20230614.ebuild
new file mode 100644
index 000000000000..18c1efcd3afe
--- /dev/null
+++ b/sys-apps/cpuid/cpuid-20230614.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Linux tool to dump x86 CPUID information about the CPUs"
+HOMEPAGE="http://www.etallen.com/cpuid.html"
+SRC_URI="http://www.etallen.com/${PN}/${P}.src.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+
+BDEPEND="
+ app-arch/gzip
+ dev-lang/perl
+"
+
+DOCS=( "ChangeLog" "FUTURE" )
+
+PATCHES=( "${FILESDIR}/${PN}-20220620-makefile.patch" )
+
+src_prepare() {
+ default
+
+ tc-export CC
+}
+
+src_install() {
+ emake BUILDROOT="${ED}" install
+
+ einstalldocs
+}