summaryrefslogtreecommitdiff
path: root/sys-apps/collectl/collectl-4.3.1-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-26 02:06:21 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-26 02:06:21 +0000
commitf9fff8823e0cd1f6570b01337ac99e5bd49c824a (patch)
tree2a69b85ea6ba19c3a6b492d49ee8cd14c887472d /sys-apps/collectl/collectl-4.3.1-r1.ebuild
parentd117172e3b48fc4be82b7623ffc40bb6070ef361 (diff)
gentoo auto-resync : 26:12:2022 - 02:06:21
Diffstat (limited to 'sys-apps/collectl/collectl-4.3.1-r1.ebuild')
-rw-r--r--sys-apps/collectl/collectl-4.3.1-r1.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/sys-apps/collectl/collectl-4.3.1-r1.ebuild b/sys-apps/collectl/collectl-4.3.1-r1.ebuild
new file mode 100644
index 000000000000..a4aa255f26f7
--- /dev/null
+++ b/sys-apps/collectl/collectl-4.3.1-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Performance monitoring tool capable of interactive reporting and logging to disk"
+HOMEPAGE="http://collectl.sourceforge.net/"
+SRC_URI="mirror://sourceforge/collectl/${P}.src.tar.gz"
+
+LICENSE="GPL-2 Artistic"
+SLOT="0"
+KEYWORDS="~alpha amd64 ~ia64 x86"
+
+RDEPEND="
+ >=dev-lang/perl-5.8.8
+ virtual/perl-Time-HiRes
+ >=dev-perl/Archive-Zip-1.20
+ sys-apps/ethtool
+ sys-apps/pciutils
+"
+
+HTML_DOCS=( docs/. )
+
+src_install() {
+ dodoc README RELEASE-collectl
+
+ dobin collectl colmux
+
+ insinto /etc
+ doins collectl.conf
+
+ insinto /usr/share/collectl
+ doins *.ph *.std
+
+ insinto /usr/share/collectl/util
+ insopts -m755
+ doins client.pl
+
+ doman man1/*
+ einstalldocs
+
+ newinitd "${FILESDIR}"/collectl.initd-2 collectl
+}