summaryrefslogtreecommitdiff
path: root/sys-apps/collectl/collectl-4.1.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sys-apps/collectl/collectl-4.1.0.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'sys-apps/collectl/collectl-4.1.0.ebuild')
-rw-r--r--sys-apps/collectl/collectl-4.1.0.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/sys-apps/collectl/collectl-4.1.0.ebuild b/sys-apps/collectl/collectl-4.1.0.ebuild
new file mode 100644
index 000000000000..5b05a88c3596
--- /dev/null
+++ b/sys-apps/collectl/collectl-4.1.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+DESCRIPTION="light-weight performance monitoring tool capable of reporting interactively and logging to disk"
+HOMEPAGE="http://collectl.sourceforge.net/"
+SRC_URI="mirror://sourceforge/collectl/${P}.src.tar.gz"
+
+LICENSE="GPL-2 Artistic"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-lang/perl-5.8.8
+ virtual/perl-Time-HiRes
+ >=dev-perl/Archive-Zip-1.20
+ sys-apps/ethtool
+ sys-apps/pciutils"
+
+src_prepare() {
+ sed -i INSTALL -e "/^DOCDIR/s:doc/collectl:doc/${PF}:" || die
+}
+
+src_install() {
+ DESTDIR="${D}" bash -ex ./INSTALL || die
+
+ rm "${D}"/etc/init.d/* || die
+ newinitd "${FILESDIR}"/collectl.initd-2 collectl
+
+ rm "${D}"/usr/share/${PN}/UNINSTALL || die
+
+ cd "${D}"/usr/share/doc/${PF} || die
+ dohtml *
+ rm ARTISTIC GPL COPYING *.html *.jpg *.css || die
+}