summaryrefslogtreecommitdiff
path: root/sys-apps/ckbcomp/ckbcomp-1.217.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-16 08:04:03 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-16 08:04:03 +0000
commit97f40b36b1afa9726e32962d11f3ac2d0bc5792e (patch)
tree1c7d586bc8a53d3b768630527bb80a477d661fa3 /sys-apps/ckbcomp/ckbcomp-1.217.ebuild
parentb435e036d9775b71048373b91d4c7c3398826858 (diff)
gentoo auto-resync : 16:02:2023 - 08:04:02
Diffstat (limited to 'sys-apps/ckbcomp/ckbcomp-1.217.ebuild')
-rw-r--r--sys-apps/ckbcomp/ckbcomp-1.217.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/sys-apps/ckbcomp/ckbcomp-1.217.ebuild b/sys-apps/ckbcomp/ckbcomp-1.217.ebuild
new file mode 100644
index 000000000000..2f1e3536465f
--- /dev/null
+++ b/sys-apps/ckbcomp/ckbcomp-1.217.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Compile an XKB keymap for loadkeys"
+HOMEPAGE="https://anonscm.debian.org/cgit/d-i/console-setup.git"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://anonscm.debian.org/git/d-i/console-setup.git"
+else
+ SRC_URI="https://salsa.debian.org/installer-team/console-setup/-/archive/${PV}/console-setup-${PV}.tar.gz"
+ S="${WORKDIR}"/console-setup-${PV}
+
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+
+RDEPEND="
+ dev-lang/perl
+ sys-apps/kbd
+ x11-misc/xkeyboard-config
+"
+
+src_compile() {
+ :
+}
+
+src_install() {
+ dobin Keyboard/ckbcomp
+}