summaryrefslogtreecommitdiff
path: root/sys-apps/ckbcomp/ckbcomp-1.164.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sys-apps/ckbcomp/ckbcomp-1.164.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'sys-apps/ckbcomp/ckbcomp-1.164.ebuild')
-rw-r--r--sys-apps/ckbcomp/ckbcomp-1.164.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/sys-apps/ckbcomp/ckbcomp-1.164.ebuild b/sys-apps/ckbcomp/ckbcomp-1.164.ebuild
new file mode 100644
index 000000000000..9f617e5cf510
--- /dev/null
+++ b/sys-apps/ckbcomp/ckbcomp-1.164.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Compile an XKB keymap for loadkeys"
+HOMEPAGE="https://anonscm.debian.org/cgit/d-i/console-setup.git"
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://anonscm.debian.org/git/d-i/console-setup.git"
+else
+ COMMIT_ID=e327df26fa9dbdf363b778ada91e83967f4bd500
+ SRC_URI="https://anonscm.debian.org/cgit/d-i/console-setup.git/snapshot/${COMMIT_ID}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+ S="${WORKDIR}/${COMMIT_ID}"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+
+DEPEND=""
+RDEPEND="
+ dev-lang/perl:*
+ sys-apps/kbd
+ x11-misc/xkeyboard-config"
+
+src_compile() {
+ :
+}
+
+src_install() {
+ dobin Keyboard/ckbcomp
+}