summaryrefslogtreecommitdiff
path: root/sys-apps/cinit/cinit-0.2.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sys-apps/cinit/cinit-0.2.1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'sys-apps/cinit/cinit-0.2.1.ebuild')
-rw-r--r--sys-apps/cinit/cinit-0.2.1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/sys-apps/cinit/cinit-0.2.1.ebuild b/sys-apps/cinit/cinit-0.2.1.ebuild
new file mode 100644
index 000000000000..c52fcc2f6738
--- /dev/null
+++ b/sys-apps/cinit/cinit-0.2.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=4
+
+inherit toolchain-funcs
+
+DESCRIPTION="a fast, small and simple init with support for profiles"
+HOMEPAGE="http://linux.schottelius.org/cinit/"
+SRC_URI="http://linux.schottelius.org/${PN}/archives/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~x86"
+IUSE="doc"
+
+src_prepare() {
+ sed -i "/contrib+tools/d" Makefile || die
+ sed -i "/^STRIP/s/strip.*/true/" Makefile.include || die
+}
+
+src_compile() {
+ emake \
+ CC="$(tc-getCC)" \
+ LD="$(tc-getCC)" \
+ CFLAGS="${CFLAGS} -I." \
+ LDFLAGS="${LDFLAGS}" \
+ STRIP=/bin/true \
+ all
+}
+
+src_install() {
+ emake LD=$(tc-getCC) DESTDIR="${D}" install
+ rm -f "${D}"/sbin/{init,shutdown,reboot}
+ dodoc Changelog CHANGES CREDITS README TODO
+ use doc && dodoc -r doc
+}