summaryrefslogtreecommitdiff
path: root/sys-apps/busybox/busybox-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-01-26 15:48:02 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-01-26 15:48:02 +0000
commit38b7258d086dd5e263c3bbe3880c8c956676bc71 (patch)
tree6fce284d5bfddaf597a490ac66069d16c6a485db /sys-apps/busybox/busybox-9999.ebuild
parent0ebf740b9c9bc7c10ac41bea315ecc6c01c79166 (diff)
gentoo resync : 25.01.2018
Diffstat (limited to 'sys-apps/busybox/busybox-9999.ebuild')
-rw-r--r--sys-apps/busybox/busybox-9999.ebuild15
1 files changed, 14 insertions, 1 deletions
diff --git a/sys-apps/busybox/busybox-9999.ebuild b/sys-apps/busybox/busybox-9999.ebuild
index 73ee93bb96b8..68000bffa174 100644
--- a/sys-apps/busybox/busybox-9999.ebuild
+++ b/sys-apps/busybox/busybox-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# See `man savedconfig.eclass` for info on how to use USE=savedconfig.
@@ -123,6 +123,13 @@ src_configure() {
# triming the BSS size may be dangerous
busybox_config_option n FEATURE_USE_BSS_TAIL
+ # These cause trouble with musl.
+ if use elibc_musl; then
+ busybox_config_option n FEATURE_UTMP
+ busybox_config_option n EXTRA_COMPAT
+ busybox_config_option n FEATURE_VI_REGEX_SEARCH
+ fi
+
# If these are not set and we are using a uclibc/busybox setup
# all calls to system() will fail.
busybox_config_option y ASH
@@ -147,6 +154,12 @@ src_configure() {
busybox_config_option systemd FEATURE_SYSTEMD
busybox_config_option math FEATURE_AWK_LIBM
+ # disable features that uClibc doesn't (yet?) provide.
+ if use elibc_uclibc; then
+ busybox_config_option n FEATURE_SYNC_FANCY #567598
+ busybox_config_option n NSENTER
+ fi
+
# all the debug options are compiler related, so punt them
busybox_config_option n DEBUG_SANITIZE
busybox_config_option n DEBUG