summaryrefslogtreecommitdiff
path: root/sys-apps/busybox/busybox-1.29.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-12-24 14:11:38 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-12-24 14:11:38 +0000
commitde49812990871e1705b64051c35161d5e6400269 (patch)
tree5e1e8fcb0ff4579dbd22a1bfee28a6b97dc8aaeb /sys-apps/busybox/busybox-1.29.3.ebuild
parent536c3711867ec947c1738f2c4b96f22e4863322d (diff)
gentoo resync : 24.12.2018
Diffstat (limited to 'sys-apps/busybox/busybox-1.29.3.ebuild')
-rw-r--r--sys-apps/busybox/busybox-1.29.3.ebuild8
1 files changed, 6 insertions, 2 deletions
diff --git a/sys-apps/busybox/busybox-1.29.3.ebuild b/sys-apps/busybox/busybox-1.29.3.ebuild
index 4d493a7ed4f5..b77ed339ae6b 100644
--- a/sys-apps/busybox/busybox-1.29.3.ebuild
+++ b/sys-apps/busybox/busybox-1.29.3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
# See `man savedconfig.eclass` for info on how to use USE=savedconfig.
@@ -16,7 +16,7 @@ if [[ ${PV} == "9999" ]] ; then
else
MY_P=${PN}-${PV/_/-}
SRC_URI="https://www.busybox.net/downloads/${MY_P}.tar.bz2"
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux"
+ KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~amd64-linux ~x86-linux"
fi
LICENSE="GPL-2" # GPL-2 only
@@ -178,6 +178,10 @@ src_configure() {
# this opt only controls mounting with <linux-2.6.23
busybox_config_option n FEATURE_MOUNT_NFS
+ # glibc-2.26 and later does not ship RPC implientation
+ busybox_config_option n FEATURE_HAVE_RPC
+ busybox_config_option n FEATURE_INETD_RPC
+
# default a bunch of uncommon options to off
local opt
for opt in \