summaryrefslogtreecommitdiff
path: root/sys-apps/bubblewrap
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-02-29 18:01:47 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-02-29 18:01:47 +0000
commitceeeb463cc1eef97fd62eaee8bf2196ba04bc384 (patch)
tree9f47ee47c31a0f13f9496879cd88a1042550aa81 /sys-apps/bubblewrap
parent53cba99042fa967e2a93da9f8db806fe2d035543 (diff)
gentoo (leap year) resync : 29.02.2020
Diffstat (limited to 'sys-apps/bubblewrap')
-rw-r--r--sys-apps/bubblewrap/Manifest2
-rw-r--r--sys-apps/bubblewrap/bubblewrap-0.3.1-r2.ebuild48
-rw-r--r--sys-apps/bubblewrap/files/bubblewrap-0.3.1-selinux-configure.patch224
3 files changed, 274 insertions, 0 deletions
diff --git a/sys-apps/bubblewrap/Manifest b/sys-apps/bubblewrap/Manifest
index f4c08cb95f7c..09689e874d8c 100644
--- a/sys-apps/bubblewrap/Manifest
+++ b/sys-apps/bubblewrap/Manifest
@@ -1,3 +1,5 @@
+AUX bubblewrap-0.3.1-selinux-configure.patch 5208 BLAKE2B 69db3066eebae54d34f02a02aa053a6bf5ed675329b3d18a4f261529a434d1c9dbfb637a3f96f4079a6adba586b666d7890370c8761c92dc9450f096a8368bbe SHA512 f6515a25c6b311c9b8336761c7daea2440964982f8a7a6587b6707ef9e9a5705ec380e13982b0765af205c221724ef418b44c3efd1b6e5f0c1788b143a88ef17
DIST bubblewrap-0.3.1.tar.xz 209924 BLAKE2B bacc4080106cd9876bf0e1ad866a7397d7d232e61a720b52b5a6b9b0d860e625511ed15ac630aa71003fb9fa145ffa9d08ae2e6ba6d1411fd75e7d9568312717 SHA512 74e36caa56540a956158445f5f38c7ac5f7ff3c733ecaf85893de4607900e1fe4050db86a4435cbe18d722e90c5b39c466c555ea8ea8d4944da6207ef1011d67
EBUILD bubblewrap-0.3.1-r1.ebuild 1052 BLAKE2B a1a1c85830ff989d7a8a879244f3bef3baaeffaf4fd8fdb5d1d4f8f35b82e249278278103c373373c00bc8bdd541ff906183d913e825cd6d4a5a61440e17cd91 SHA512 bf27b1bcaab8be6f41362f75e82881389bf414df620a82f3ee157661a925e87292607cd5d5c5ead28db832a0ae1418963054d6c4c66c0858152987e42adb3b6d
+EBUILD bubblewrap-0.3.1-r2.ebuild 1136 BLAKE2B 939a81795692cd5e101d835d8de0afe00a45dd05b77f6976ae86adf58f44a2ee1bf28bbcaf103299958db9368b4049b3112540bb483d692abdad8cd9a067a982 SHA512 8c3101a668a3ac28a37e55a7618b0dd4da6bb7482eb60648dbeb8fae03494c4ed0def4bd76ee6065acbe862f93c9b70c4c424ee2159d1b4f1d83671792d3d7a6
MISC metadata.xml 342 BLAKE2B de8d3ba1c95b39bd6e582b27b186ef0805fd9be1fe6c806fb8bcfa28f7cafb3a2068be0e21baa13ca08895db0d0b666b5c1eab573f38fac251ce9d41c793866e SHA512 25752c1aae465ac49409e35c32863b945c1dc8989ddb4fab2999cf890cf4ec33fc82e9324e3af49c15a8580a566e5f737ec270646b4cc569c3c5dd472eb1b2bb
diff --git a/sys-apps/bubblewrap/bubblewrap-0.3.1-r2.ebuild b/sys-apps/bubblewrap/bubblewrap-0.3.1-r2.ebuild
new file mode 100644
index 000000000000..6eef70036753
--- /dev/null
+++ b/sys-apps/bubblewrap/bubblewrap-0.3.1-r2.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit bash-completion-r1 linux-info
+
+DESCRIPTION="Unprivileged sandboxing tool, namespaces-powered chroot-like solution"
+HOMEPAGE="https://github.com/projectatomic/bubblewrap"
+SRC_URI="https://github.com/projectatomic/${PN}/releases/download/v${PV}/${P}.tar.xz"
+
+LICENSE="LGPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="selinux +suid"
+
+RDEPEND="
+ sys-libs/libseccomp
+ sys-libs/libcap
+ selinux? ( >=sys-libs/libselinux-2.1.9 )
+"
+DEPEND="${RDEPEND}
+ app-text/docbook-xml-dtd:4.3
+ app-text/docbook-xsl-stylesheets
+ dev-libs/libxslt
+ virtual/pkgconfig
+"
+
+# tests require root priviledge
+RESTRICT="test"
+PATCHES=(
+ "${FILESDIR}/bubblewrap-0.3.1-selinux-configure.patch" # bug 674312
+)
+
+pkg_setup() {
+ if [[ ${MERGE_TYPE} != buildonly ]]; then
+ CONFIG_CHECK="~UTS_NS ~IPC_NS ~USER_NS ~PID_NS ~NET_NS"
+ linux-info_pkg_setup
+ fi
+}
+
+src_configure() {
+ econf \
+ $(use_enable selinux) \
+ "--enable-man" \
+ "--with-bash-completion-dir=$(get_bashcompdir)" \
+ "--with-priv-mode=$(usex suid setuid none)"
+}
diff --git a/sys-apps/bubblewrap/files/bubblewrap-0.3.1-selinux-configure.patch b/sys-apps/bubblewrap/files/bubblewrap-0.3.1-selinux-configure.patch
new file mode 100644
index 000000000000..b8fad6cc1685
--- /dev/null
+++ b/sys-apps/bubblewrap/files/bubblewrap-0.3.1-selinux-configure.patch
@@ -0,0 +1,224 @@
+Author: Jonas Jelten <jj@sft.mx>
+
+upstream decided to ship the generated ./configure file...
+here's the updated configure script with the missing PKG_PROG_PKG_CONFIG call
+
+===================================================================
+--- bubblewrap-0.3.1.orig/configure
++++ bubblewrap-0.3.1/configure
+@@ -5224,107 +5224,6 @@ ac_compiler_gnu=$ac_cv_c_compiler_gnu
+
+
+
+-for ac_header in sys/capability.h
+-do :
+- ac_fn_c_check_header_mongrel "$LINENO" "sys/capability.h" "ac_cv_header_sys_capability_h" "$ac_includes_default"
+-if test "x$ac_cv_header_sys_capability_h" = xyes; then :
+- cat >>confdefs.h <<_ACEOF
+-#define HAVE_SYS_CAPABILITY_H 1
+-_ACEOF
+-
+-else
+- as_fn_error $? "*** POSIX caps headers not found" "$LINENO" 5
+-fi
+-
+-done
+-
+-
+-# Check whether --enable-man was given.
+-if test "${enable_man+set}" = set; then :
+- enableval=$enable_man;
+-else
+- enable_man=maybe
+-fi
+-
+-
+-if test "$enable_man" != no; then :
+-
+- # Extract the first word of "xsltproc", so it can be a program name with args.
+-set dummy xsltproc; ac_word=$2
+-{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for $ac_word" >&5
+-$as_echo_n "checking for $ac_word... " >&6; }
+-if ${ac_cv_path_XSLTPROC+:} false; then :
+- $as_echo_n "(cached) " >&6
+-else
+- case $XSLTPROC in
+- [\\/]* | ?:[\\/]*)
+- ac_cv_path_XSLTPROC="$XSLTPROC" # Let the user override the test with a path.
+- ;;
+- *)
+- as_save_IFS=$IFS; IFS=$PATH_SEPARATOR
+-for as_dir in $PATH
+-do
+- IFS=$as_save_IFS
+- test -z "$as_dir" && as_dir=.
+- for ac_exec_ext in '' $ac_executable_extensions; do
+- if as_fn_executable_p "$as_dir/$ac_word$ac_exec_ext"; then
+- ac_cv_path_XSLTPROC="$as_dir/$ac_word$ac_exec_ext"
+- $as_echo "$as_me:${as_lineno-$LINENO}: found $as_dir/$ac_word$ac_exec_ext" >&5
+- break 2
+- fi
+-done
+- done
+-IFS=$as_save_IFS
+-
+- ;;
+-esac
+-fi
+-XSLTPROC=$ac_cv_path_XSLTPROC
+-if test -n "$XSLTPROC"; then
+- { $as_echo "$as_me:${as_lineno-$LINENO}: result: $XSLTPROC" >&5
+-$as_echo "$XSLTPROC" >&6; }
+-else
+- { $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
+-$as_echo "no" >&6; }
+-fi
+-
+-
+- if test -z "$XSLTPROC"; then :
+-
+- if test "$enable_man" = yes; then :
+-
+- as_fn_error $? "xsltproc is required for --enable-man" "$LINENO" 5
+-
+-fi
+- enable_man=no
+-
+-else
+-
+- enable_man=yes
+-
+-fi
+-
+-fi
+- if test "$enable_man" != no; then
+- ENABLE_MAN_TRUE=
+- ENABLE_MAN_FALSE='#'
+-else
+- ENABLE_MAN_TRUE='#'
+- ENABLE_MAN_FALSE=
+-fi
+-
+-
+-
+-# Check whether --with-bash-completion-dir was given.
+-if test "${with_bash_completion_dir+set}" = set; then :
+- withval=$with_bash_completion_dir;
+-else
+- with_bash_completion_dir=yes
+-fi
+-
+-
+-if test "x$with_bash_completion_dir" = "xyes"; then
+-
+
+
+
+@@ -5445,6 +5344,107 @@ $as_echo "no" >&6; }
+ fi
+ fi
+
++for ac_header in sys/capability.h
++do :
++ ac_fn_c_check_header_mongrel "$LINENO" "sys/capability.h" "ac_cv_header_sys_capability_h" "$ac_includes_default"
++if test "x$ac_cv_header_sys_capability_h" = xyes; then :
++ cat >>confdefs.h <<_ACEOF
++#define HAVE_SYS_CAPABILITY_H 1
++_ACEOF
++
++else
++ as_fn_error $? "*** POSIX caps headers not found" "$LINENO" 5
++fi
++
++done
++
++
++# Check whether --enable-man was given.
++if test "${enable_man+set}" = set; then :
++ enableval=$enable_man;
++else
++ enable_man=maybe
++fi
++
++
++if test "$enable_man" != no; then :
++
++ # Extract the first word of "xsltproc", so it can be a program name with args.
++set dummy xsltproc; ac_word=$2
++{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for $ac_word" >&5
++$as_echo_n "checking for $ac_word... " >&6; }
++if ${ac_cv_path_XSLTPROC+:} false; then :
++ $as_echo_n "(cached) " >&6
++else
++ case $XSLTPROC in
++ [\\/]* | ?:[\\/]*)
++ ac_cv_path_XSLTPROC="$XSLTPROC" # Let the user override the test with a path.
++ ;;
++ *)
++ as_save_IFS=$IFS; IFS=$PATH_SEPARATOR
++for as_dir in $PATH
++do
++ IFS=$as_save_IFS
++ test -z "$as_dir" && as_dir=.
++ for ac_exec_ext in '' $ac_executable_extensions; do
++ if as_fn_executable_p "$as_dir/$ac_word$ac_exec_ext"; then
++ ac_cv_path_XSLTPROC="$as_dir/$ac_word$ac_exec_ext"
++ $as_echo "$as_me:${as_lineno-$LINENO}: found $as_dir/$ac_word$ac_exec_ext" >&5
++ break 2
++ fi
++done
++ done
++IFS=$as_save_IFS
++
++ ;;
++esac
++fi
++XSLTPROC=$ac_cv_path_XSLTPROC
++if test -n "$XSLTPROC"; then
++ { $as_echo "$as_me:${as_lineno-$LINENO}: result: $XSLTPROC" >&5
++$as_echo "$XSLTPROC" >&6; }
++else
++ { $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
++$as_echo "no" >&6; }
++fi
++
++
++ if test -z "$XSLTPROC"; then :
++
++ if test "$enable_man" = yes; then :
++
++ as_fn_error $? "xsltproc is required for --enable-man" "$LINENO" 5
++
++fi
++ enable_man=no
++
++else
++
++ enable_man=yes
++
++fi
++
++fi
++ if test "$enable_man" != no; then
++ ENABLE_MAN_TRUE=
++ ENABLE_MAN_FALSE='#'
++else
++ ENABLE_MAN_TRUE='#'
++ ENABLE_MAN_FALSE=
++fi
++
++
++
++# Check whether --with-bash-completion-dir was given.
++if test "${with_bash_completion_dir+set}" = set; then :
++ withval=$with_bash_completion_dir;
++else
++ with_bash_completion_dir=yes
++fi
++
++
++if test "x$with_bash_completion_dir" = "xyes"; then
++
+ pkg_failed=no
+ { $as_echo "$as_me:${as_lineno-$LINENO}: checking for BASH_COMPLETION" >&5
+ $as_echo_n "checking for BASH_COMPLETION... " >&6; }