summaryrefslogtreecommitdiff
path: root/sys-apps/bubblewrap/bubblewrap-0.6.2-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-09 15:43:36 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-09 15:43:36 +0100
commit2719f73b6813d11d13a9650cdd2ab8ec6e69385d (patch)
tree8c816148bcbd22757d892089c989ae614eae4f5a /sys-apps/bubblewrap/bubblewrap-0.6.2-r1.ebuild
parent0f558761aa2dee1017b4751e4017205e015a9560 (diff)
gentoo resync : 09.07.2022
Diffstat (limited to 'sys-apps/bubblewrap/bubblewrap-0.6.2-r1.ebuild')
-rw-r--r--sys-apps/bubblewrap/bubblewrap-0.6.2-r1.ebuild58
1 files changed, 58 insertions, 0 deletions
diff --git a/sys-apps/bubblewrap/bubblewrap-0.6.2-r1.ebuild b/sys-apps/bubblewrap/bubblewrap-0.6.2-r1.ebuild
new file mode 100644
index 000000000000..fa95d51552b8
--- /dev/null
+++ b/sys-apps/bubblewrap/bubblewrap-0.6.2-r1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit linux-info meson
+
+DESCRIPTION="Unprivileged sandboxing tool, namespaces-powered chroot-like solution"
+HOMEPAGE="https://github.com/containers/bubblewrap/"
+SRC_URI="https://github.com/containers/${PN}/releases/download/v${PV}/${P}.tar.xz"
+
+LICENSE="LGPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~x86"
+IUSE="selinux suid"
+
+RDEPEND="
+ sys-libs/libseccomp
+ sys-libs/libcap
+ selinux? ( >=sys-libs/libselinux-2.1.9 )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ app-text/docbook-xml-dtd:4.3
+ app-text/docbook-xsl-stylesheets
+ dev-libs/libxslt
+ virtual/pkgconfig
+"
+
+# tests require root privileges
+RESTRICT="test"
+
+pkg_setup() {
+ if [[ ${MERGE_TYPE} != buildonly ]]; then
+ CONFIG_CHECK="~UTS_NS ~IPC_NS ~USER_NS ~PID_NS ~NET_NS"
+ linux-info_pkg_setup
+ fi
+}
+
+src_configure() {
+ local emesonargs=(
+ -Dbash_completion=enabled
+ -Dman=enabled
+ -Dtests=false
+ -Dzsh_completion=enabled
+ $(meson_feature selinux)
+ )
+
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+
+ if use suid; then
+ chmod u+s "${ED}"/usr/bin/bwrap
+ fi
+}