summaryrefslogtreecommitdiff
path: root/sys-apps/bleachbit
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-10-13 22:19:36 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-10-14 23:22:23 +0100
commit4b19be30aa626b327c885dae62c559ec0e9fb935 (patch)
tree76e74807bc479502e13866b581b6bf86734ec634 /sys-apps/bleachbit
parent30d6f67c98d149508509d5e86f176d558793acc0 (diff)
gentoo resync : 13.10.2019
Diffstat (limited to 'sys-apps/bleachbit')
-rw-r--r--sys-apps/bleachbit/Manifest2
-rw-r--r--sys-apps/bleachbit/bleachbit-2.3.ebuild59
2 files changed, 61 insertions, 0 deletions
diff --git a/sys-apps/bleachbit/Manifest b/sys-apps/bleachbit/Manifest
index b80f14324a89..d976c35881c2 100644
--- a/sys-apps/bleachbit/Manifest
+++ b/sys-apps/bleachbit/Manifest
@@ -1,3 +1,5 @@
DIST bleachbit-2.2.tar.gz 1100913 BLAKE2B a16e63a2533f9d9c385d384e2fd65dbb32a8f064e769f99e8a8cab9c4069cc7b21e6896c5fa8d02d8204e8c93da8a5f66605601eb44ecc354d41f1a6d9fe2d0a SHA512 c7661cc64358a6420768c3ee1a6ec97d2fd4f0bf67b393be045ef79cef8b3f8cc273a51a5dd7c79d89b8a14cd1357f7714fc860addc9ae74af48bd8d427b3a5a
+DIST bleachbit-2.3.tar.gz 1167950 BLAKE2B 61f7248ade73be167a8717ea63f4fc3c899ed437b2bd2bcdfbcdf844a5259056bbf4e90e0142d0b6ca393daf796067ff3f39eef1beef275f44ea7f4f16ee0a46 SHA512 27e6ddfa5dd773cd27508e566aa5ef3fe790543a6737a35e9c92fcebbb5f6d5a5e30faa52ce8c3cb70b0aadcfa4b1a48ed3622e3ed6fca9e35a3dfea7426f098
EBUILD bleachbit-2.2.ebuild 1192 BLAKE2B 0bfa92eccb8cd0a08b482870ebfc68bbe09c576d2cb6d2001ca57ed458ef7a3b8e6f9fea3cfd1db07a530363042d3db40bf96e96ad03fd08fc39ed18f6ac9116 SHA512 ce6a55df1b36909d55ef369b4ad61b5097cd3a86702dc9c5606b78386ddbdd90a8048a3d0aedf82955fc025907bc7698949fcf10b00e47ea65a40ea597b327e0
+EBUILD bleachbit-2.3.ebuild 1226 BLAKE2B b054846675ae6708876229d270771a0d7a62ba2a7a2cebe100f4f5085494bd6ea04e51eced89d7cd261eb4170bc35bd0da9575117189bcfc29d41ebce3c2fffd SHA512 ce03256b526a17e343dd74a4eeaa5e416a381ce1fa841a73dcc83758c5f12d91081186b522421ba0d78745b2f47f277db334eea713e0337ecbd99f70038f1cf9
MISC metadata.xml 526 BLAKE2B f55f30792d579d5fc57553b3aa8a8f97d450778a1813c53e82a0fea4cc01fe3039d249ed89c8097a973c1bd923390e3bd1b85ae1a1d2386ab3373a9baae08623 SHA512 d2179dee28e6bacaa540039b726eb5ab47b87abc73a5c86621de3230f3d6355d082e8189c9e167871fb8c15975815341ce02bbef80195b984728c3b1b0652bf1
diff --git a/sys-apps/bleachbit/bleachbit-2.3.ebuild b/sys-apps/bleachbit/bleachbit-2.3.ebuild
new file mode 100644
index 000000000000..903b5a3f45cb
--- /dev/null
+++ b/sys-apps/bleachbit/bleachbit-2.3.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="sqlite(+)"
+
+inherit desktop distutils-r1
+
+DESCRIPTION="Clean junk to free disk space and to maintain privacy"
+HOMEPAGE="https://www.bleachbit.org"
+SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+gtk"
+
+RDEPEND="
+ dev-python/chardet[$PYTHON_USEDEP]
+ dev-python/scandir[$PYTHON_USEDEP]
+ gtk? ( dev-python/pygobject:3[$PYTHON_USEDEP] )
+"
+BDEPEND="
+ dev-python/setuptools[$PYTHON_USEDEP]
+ sys-devel/gettext
+"
+
+python_prepare_all() {
+ # choose correct Python implementation, bug #465254
+ sed -i 's/python/$(PYTHON)/g' po/Makefile || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ emake -C po local
+}
+
+python_install() {
+ distutils-r1_python_install
+ python_newscript ${PN}.py ${PN}
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ emake -C po DESTDIR="${D}" install
+
+ # https://bugs.gentoo.org/388999
+ insinto /usr/share/bleachbit/cleaners
+ doins cleaners/*.xml
+
+ insinto /usr/share/bleachbit
+ doins data/app-menu.ui
+
+ doicon ${PN}.png
+ domenu ${PN}.desktop
+}