summaryrefslogtreecommitdiff
path: root/sys-apps/bar/bar-1.11.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-12-03 16:17:22 +0000
committerV3n3RiX <venerix@redcorelinux.org>2017-12-03 16:17:22 +0000
commit4cd2370bed609c118b6edfde5d3f116e5c35b897 (patch)
treeec58f2c41f49754e41521d5ebc9dce4597ddd0a5 /sys-apps/bar/bar-1.11.1.ebuild
parentf443475c824b4b5c086e6d040961cb35ad81bc60 (diff)
gentoo resync : 03.12.2017
Diffstat (limited to 'sys-apps/bar/bar-1.11.1.ebuild')
-rw-r--r--sys-apps/bar/bar-1.11.1.ebuild27
1 files changed, 13 insertions, 14 deletions
diff --git a/sys-apps/bar/bar-1.11.1.ebuild b/sys-apps/bar/bar-1.11.1.ebuild
index ff678910027e..0d1aadd2a030 100644
--- a/sys-apps/bar/bar-1.11.1.ebuild
+++ b/sys-apps/bar/bar-1.11.1.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=4
+EAPI=6
inherit autotools
@@ -18,31 +18,30 @@ DEPEND="doc? ( >=app-doc/doxygen-1.3.5 )"
RDEPEND=""
src_prepare() {
- sed -e '/^LDFLAGS/d' \
- -e '/cd $(WEB_DIR) && $(MAKE)/d' -i Makefile.am || die
+ default
+ sed '/cd $(WEB_DIR) && $(MAKE)/d' -i Makefile.am || die
eautomake
}
src_configure() {
- local myconf
-
- # Fix wrt #113392
- use sparc && myconf="${myconf} --disable-use-memalign"
- econf ${myconf}
+ # Fix bug 113392
+ econf $(use_enable !sparc use-memalign)
}
src_compile() {
emake CFLAGS="${CFLAGS}"
+
if use doc; then
- mkdir -p ../www/doxygen/${PV}
+ mkdir -p ../www/doxygen/${PV} || die
emake update-www
+ HTML_DOCS=( ../www/doxygen/${PV}/html/. )
+
+ # remove doxygen working files
+ find ../www/doxygen/${PV}/html \( -iname '*.map' -o -iname '*.md5' \) -delete || die
fi
}
src_install() {
- emake DESTDIR="${D}" install
- dodoc AUTHORS TODO TROUBLESHOOTING debian/changelog
- if use doc ; then
- dohtml -r ../www/doxygen/${PV}/html/*
- fi
+ default
+ dodoc TROUBLESHOOTING debian/changelog
}