summaryrefslogtreecommitdiff
path: root/sys-apps/azure-nvme-utils/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-05-10 00:01:14 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-05-10 00:01:14 +0100
commit17e5f1ea4a2e1c5664f96480ca46348d008e8711 (patch)
tree7166d1b58a582290a4ad23ff5882cca911b8035c /sys-apps/azure-nvme-utils/files
parenta0ce545d52f231499bf9f3644493113d8af58ec9 (diff)
gentoo auto-resync : 10:05:2024 - 00:01:13
Diffstat (limited to 'sys-apps/azure-nvme-utils/files')
-rw-r--r--sys-apps/azure-nvme-utils/files/azure-nvme-utils-werror.patch31
1 files changed, 31 insertions, 0 deletions
diff --git a/sys-apps/azure-nvme-utils/files/azure-nvme-utils-werror.patch b/sys-apps/azure-nvme-utils/files/azure-nvme-utils-werror.patch
new file mode 100644
index 000000000000..928dcb099e4e
--- /dev/null
+++ b/sys-apps/azure-nvme-utils/files/azure-nvme-utils-werror.patch
@@ -0,0 +1,31 @@
+From d4afc19a9432e1b7c25269732d18143263f87404 Mon Sep 17 00:00:00 2001
+From: James Le Cuirot <jlecuirot@microsoft.com>
+Date: Fri, 3 May 2024 12:52:04 +0100
+Subject: [PATCH] cmake: Only enable -Werror for debug builds
+
+-Werror is very unhelpful for distributions and end users as different
+(usually newer) compilers will raise warnings that the maintainers may
+not see. The warnings should get reported upstream, but they shouldn't
+block users from using the software.
+
+Signed-off-by: James Le Cuirot <jlecuirot@microsoft.com>
+---
+ CMakeLists.txt | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 3d3cd4b..75db578 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -17,7 +17,7 @@ include(cmake/doc.cmake)
+ include(CTest)
+ enable_testing()
+
+-add_compile_options(-Wextra -Wall -Werror -std=gnu11 -D_GNU_SOURCE=1)
++add_compile_options(-Wextra -Wall $<$<CONFIG:Debug>:-Werror> -std=gnu11 -D_GNU_SOURCE=1)
+ add_executable(azure-nvme-id src/main.c)
+
+ set(AZURE_NVME_ID_INSTALL_DIR "${CMAKE_INSTALL_PREFIX}/sbin")
+--
+2.44.0
+