summaryrefslogtreecommitdiff
path: root/sys-apps/audio-entropyd/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sys-apps/audio-entropyd/files
reinit the tree, so we can have metadata
Diffstat (limited to 'sys-apps/audio-entropyd/files')
-rw-r--r--sys-apps/audio-entropyd/files/audio-entropyd-2.0.1-ldflags.patch13
-rw-r--r--sys-apps/audio-entropyd/files/audio-entropyd-2.0.1-uclibc.patch27
-rw-r--r--sys-apps/audio-entropyd/files/audio-entropyd.conf-212
-rw-r--r--sys-apps/audio-entropyd/files/audio-entropyd.init-226
-rw-r--r--sys-apps/audio-entropyd/files/audio-entropyd.service8
5 files changed, 86 insertions, 0 deletions
diff --git a/sys-apps/audio-entropyd/files/audio-entropyd-2.0.1-ldflags.patch b/sys-apps/audio-entropyd/files/audio-entropyd-2.0.1-ldflags.patch
new file mode 100644
index 000000000000..870e9121140d
--- /dev/null
+++ b/sys-apps/audio-entropyd/files/audio-entropyd-2.0.1-ldflags.patch
@@ -0,0 +1,13 @@
+diff --git a/Makefile b/Makefile
+index 95a84a6..340f95f 100644
+--- a/Makefile
++++ b/Makefile
+@@ -12,7 +12,7 @@ TARGETS=audio-entropyd
+ all: $(TARGETS)
+
+ audio-entropyd: audio-entropyd.o error.o proc.o val.o RNGTEST.o error.o
+- $(CC) -o $@ $^ $(LFLAGS)
++ $(CC) $(LDFLAGS) -o $@ $^ $(LFLAGS)
+
+ install: audio-entropyd
+ cp audio-entropyd /usr/local/sbin/
diff --git a/sys-apps/audio-entropyd/files/audio-entropyd-2.0.1-uclibc.patch b/sys-apps/audio-entropyd/files/audio-entropyd-2.0.1-uclibc.patch
new file mode 100644
index 000000000000..bdf5adeff825
--- /dev/null
+++ b/sys-apps/audio-entropyd/files/audio-entropyd-2.0.1-uclibc.patch
@@ -0,0 +1,27 @@
+--- audio-entropyd-1.0.1.orig/error.c 2008-01-22 09:50:28 +0000
++++ audio-entropyd-1.0.1/error.c 2008-01-22 09:53:51 +0000
+@@ -9,13 +9,13 @@
+ #include <signal.h>
+ #include <syslog.h>
+ #include <regex.h>
+-#if defined(__GLIBC__)
++#if defined(__GLIBC__) && !defined(__UCLIBC__)
+ #include <execinfo.h>
+ #endif
+
+ void print_trace(void)
+ {
+-#if defined(__GLIBC__)
++#if defined(__GLIBC__) && !defined(__UCLIBC__)
+ void *array[MAX_BACKTRACE_LENGTH];
+ size_t size;
+
+@@ -39,7 +39,7 @@
+ printf("\n\n\nDebug information:\n");
+ if (errno) fprintf(stderr, "errno: %d=%s (if applicable)\n", errno, strerror(errno));
+
+-#if defined(__GLIBC__)
++#if defined(__GLIBC__) && !defined(__UCLIBC__)
+ print_trace();
+ #endif
+
diff --git a/sys-apps/audio-entropyd/files/audio-entropyd.conf-2 b/sys-apps/audio-entropyd/files/audio-entropyd.conf-2
new file mode 100644
index 000000000000..d39ddfca29fa
--- /dev/null
+++ b/sys-apps/audio-entropyd/files/audio-entropyd.conf-2
@@ -0,0 +1,12 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+# /etc/conf.d/audio-entropyd
+
+# The acceptable values are DEVICE, READSIZE and SAMPLERATE
+# These defaults give the optimum entropy
+
+#DEVICE="hw:0"
+
+#SAMPLERATE must be a valid sampling rate of your audio source
+SAMPLERATE="44050"
diff --git a/sys-apps/audio-entropyd/files/audio-entropyd.init-2 b/sys-apps/audio-entropyd/files/audio-entropyd.init-2
new file mode 100644
index 000000000000..ff59a659022d
--- /dev/null
+++ b/sys-apps/audio-entropyd/files/audio-entropyd.init-2
@@ -0,0 +1,26 @@
+#!/sbin/openrc-run
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+depend() {
+ need modules
+ use alsasound
+ provide entropy
+}
+
+start() {
+ local params=""
+ [ -n "$DEVICE" ] && params="$params -d $DEVICE"
+ [ -n "$SAMPLERATE" ] && params="$params -N $SAMPLERATE"
+
+ ebegin "Starting audio entropy gathering daemon"
+ start-stop-daemon --start --quiet --pidfile /var/run/audio-entropyd.pid \
+ --exec /usr/sbin/audio-entropyd -- ${params}
+ eend ${?}
+}
+
+stop() {
+ ebegin "Stopping audio entropy gathering daemon"
+ start-stop-daemon --stop --quiet --pidfile /var/run/audio-entropyd.pid
+ eend ${?}
+}
diff --git a/sys-apps/audio-entropyd/files/audio-entropyd.service b/sys-apps/audio-entropyd/files/audio-entropyd.service
new file mode 100644
index 000000000000..849ad0131c63
--- /dev/null
+++ b/sys-apps/audio-entropyd/files/audio-entropyd.service
@@ -0,0 +1,8 @@
+[Unit]
+Description=Audio Entropy Daemon
+
+[Service]
+ExecStart=/usr/sbin/audio-entropyd -n
+
+[Install]
+WantedBy=multi-user.target