summaryrefslogtreecommitdiff
path: root/sys-apps/apply-default-acl/apply-default-acl-0.4.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-06-13 10:39:22 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-06-13 10:39:22 +0100
commit9452a6e87b6c2c70513bc47a2470bf9f1168920e (patch)
tree8ac67e26b45f34d71c5aab3621813b100a0d5f00 /sys-apps/apply-default-acl/apply-default-acl-0.4.4.ebuild
parentf516638b7fe9592837389826a6152a7e1b251c54 (diff)
gentoo resync : 13.06.2020
Diffstat (limited to 'sys-apps/apply-default-acl/apply-default-acl-0.4.4.ebuild')
-rw-r--r--sys-apps/apply-default-acl/apply-default-acl-0.4.4.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/sys-apps/apply-default-acl/apply-default-acl-0.4.4.ebuild b/sys-apps/apply-default-acl/apply-default-acl-0.4.4.ebuild
new file mode 100644
index 000000000000..956755978eab
--- /dev/null
+++ b/sys-apps/apply-default-acl/apply-default-acl-0.4.4.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Apply default POSIX ACLs to files and directories"
+HOMEPAGE="http://michael.orlitzky.com/code/apply-default-acl.xhtml"
+SRC_URI="http://michael.orlitzky.com/code/releases/${P}.tar.xz"
+
+LICENSE="AGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="sys-apps/acl"
+RDEPEND="${DEPEND}"
+
+DOCS=( doc/README )
+
+# tests need to be executed on filesystem with ACL support
+# skipping them for now
+RESTRICT="test"
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
+}