summaryrefslogtreecommitdiff
path: root/sys-apps/apparmor-utils/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sys-apps/apparmor-utils/files
reinit the tree, so we can have metadata
Diffstat (limited to 'sys-apps/apparmor-utils/files')
-rw-r--r--sys-apps/apparmor-utils/files/apparmor-utils-2.11-shebang.patch16
1 files changed, 16 insertions, 0 deletions
diff --git a/sys-apps/apparmor-utils/files/apparmor-utils-2.11-shebang.patch b/sys-apps/apparmor-utils/files/apparmor-utils-2.11-shebang.patch
new file mode 100644
index 000000000000..3dce7c261688
--- /dev/null
+++ b/sys-apps/apparmor-utils/files/apparmor-utils-2.11-shebang.patch
@@ -0,0 +1,16 @@
+Avoid rewriting the shebang.
+
+The ebuild will take care of this when replicating the script for each of the
+supported python implementations.
+
+--- a/utils/python-tools-setup.py
++++ b/utils/python-tools-setup.py
+@@ -43,7 +43,7 @@
+ f = prefix + s
+ # If we have a defined python version, use it instead of the system
+ # default
+- if 'PYTHON' in os.environ:
++ if False:
+ lines = open(os.path.basename(s)).readlines()
+ lines[0] = '#! /usr/bin/env %s\n' % os.environ['PYTHON']
+ open(f, 'w').write("".join(lines))