summaryrefslogtreecommitdiff
path: root/sec-keys/openpgp-keys-thomasdickey/openpgp-keys-thomasdickey-20220428.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
committerV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
commit752d6256e5204b958b0ef7905675a940b5e9172f (patch)
tree330d16e6362a49cbed8875a777fe641a43376cd3 /sec-keys/openpgp-keys-thomasdickey/openpgp-keys-thomasdickey-20220428.ebuild
parent0c100b7dd2b30e75b799d806df4ef899fd98e1ea (diff)
gentoo resync : 12.05.2022
Diffstat (limited to 'sec-keys/openpgp-keys-thomasdickey/openpgp-keys-thomasdickey-20220428.ebuild')
-rw-r--r--sec-keys/openpgp-keys-thomasdickey/openpgp-keys-thomasdickey-20220428.ebuild19
1 files changed, 19 insertions, 0 deletions
diff --git a/sec-keys/openpgp-keys-thomasdickey/openpgp-keys-thomasdickey-20220428.ebuild b/sec-keys/openpgp-keys-thomasdickey/openpgp-keys-thomasdickey-20220428.ebuild
new file mode 100644
index 000000000000..8505dfa9eec8
--- /dev/null
+++ b/sec-keys/openpgp-keys-thomasdickey/openpgp-keys-thomasdickey-20220428.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="OpenPGP keys used by Thomas Dickey"
+HOMEPAGE="https://invisible-island.net/public/public.html"
+SRC_URI="https://invisible-island.net/public/dickey@invisible-island.net-rsa3072.asc -> ${P}-dickey@invisible-island.net-rsa3072.asc"
+S="${WORKDIR}"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86"
+
+src_install() {
+ local files=( ${A} )
+ insinto /usr/share/openpgp-keys
+ newins - thomasdickey.asc < <(cat "${files[@]/#/${DISTDIR}/}" || die)
+}