summaryrefslogtreecommitdiff
path: root/sec-keys/openpgp-keys-tcpdump/openpgp-keys-tcpdump-20240308.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-03-08 19:07:58 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-03-08 19:07:58 +0000
commit8edd4a48a39640822abe6ddb7b2a1d5b2da4ea70 (patch)
treedd40a3ea9cdcc06c8c63bd2ee71c2c2c0ea11549 /sec-keys/openpgp-keys-tcpdump/openpgp-keys-tcpdump-20240308.ebuild
parent7825305c5ddf11fffe24fa30453c4e8468f64305 (diff)
gentoo auto-resync : 08:03:2024 - 19:07:58
Diffstat (limited to 'sec-keys/openpgp-keys-tcpdump/openpgp-keys-tcpdump-20240308.ebuild')
-rw-r--r--sec-keys/openpgp-keys-tcpdump/openpgp-keys-tcpdump-20240308.ebuild20
1 files changed, 20 insertions, 0 deletions
diff --git a/sec-keys/openpgp-keys-tcpdump/openpgp-keys-tcpdump-20240308.ebuild b/sec-keys/openpgp-keys-tcpdump/openpgp-keys-tcpdump-20240308.ebuild
new file mode 100644
index 000000000000..b2785d28d201
--- /dev/null
+++ b/sec-keys/openpgp-keys-tcpdump/openpgp-keys-tcpdump-20240308.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="OpenPGP keys used to sign tcpdump releases"
+HOMEPAGE="https://www.tcpdump.org/index.html#latest-releases"
+SRC_URI="https://www.tcpdump.org/release/signing-key.asc -> ${P}.asc"
+S="${WORKDIR}"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+src_install() {
+ local files=( ${A} )
+
+ insinto /usr/share/openpgp-keys
+ newins - tcpdump.asc < <(cat "${files[@]/#/${DISTDIR}/}" || die)
+}